OSPF Update

Answered Question
Dec 1st, 2008
User Badges:

Hello,


I have site-to-site VPN between HQ & branch-office

OSPF is the routing protocol used between VPN Tunnel.

Since I have limited bandwidth at branch-office ;

I need to restrict ospf update once a day


I need to know ; how to restrict the updates once a day



Correct Answer by Joseph W. Doherty about 8 years 7 months ago

Giuseppe, you're welcome, although I regret being the one to reduce your "batting average" to only .999 ;)


"I was focusing on the fact that demand circuits can be useless if you keep the link in area 0 where it is exposed to every topology change. "


Perhaps, but even within area 0, you might design a very stable area 0 topology if you have just area summary addresses and externals injected by statics. I.e., it might not always be useless even within area 0. However, it does make more sense, to restrict the technique to stub areas.


PS:

Amin, stepping back just a little, the real purpose for this technique was to avoid repeatly bringing up a dial-up/on-demand link for just routing hellos and avoiding toll charges, not so much to save bandwidth across the link when it was available. As Giuseppe also noted in his first post, OSPF maintenance bandwidth usage is low.


Careful OSPF design and tuning OSPF parameters can further minimize OSPF's bandwidth utilization (along with speeding convergence and increasing stability).


For your purposes, the real bandwidth savings of this technique is avoidance of periodic OSPF hellos (which don't use much bandwidth) or the periodic LSA refresh (bandwidth?), but unless you look carefully at your overall design, you could still have a lot happening when there is OSPF topology activity.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Giuseppe Larosa Mon, 12/01/2008 - 13:16
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Amin,

you could use the OSPF demand circuit option that will set the donotage field in LSA but:


the interface command is:

ip ospf demand-circuit



be aware that this doesn't stop OSPF hellos


A careful design using a totally stub area can reduce the OSPF exchange to a minimum of a single default route + hub router LSA.

The normal exchange or OSPF LSA refresh happens every 30 minutes so the bandwidth usage is very low in the case of totally stub area and can be tolerated in normal scenarios even if low speed.


Hope to help

Giuseppe


Amin Shaikh Mon, 12/01/2008 - 13:28
User Badges:

Thanks.. but with ip ospf demand-circuit you cannot define update-time???


I have noticed in my scenario the OSPF gets updated every 7-to-10 minutes??? Dont know why..


I have simple ospf config at branch-office i.e


router ospf 10

network 192.168.1.0 0.0.0.255 area 0


Now as per your suggestion to make it stub area ; wht commands exactly I need to enter under ospf process..

Giuseppe Larosa Mon, 12/01/2008 - 13:40
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Amin,


on hub router :


router ospf 10

area 25 stub no summary

network 192.168.1.0 0.0.0.255 area 25

!

on branch router:


router ospf 10

area 25 stub

network 192.168.1.0 0.0.0.255 area 25

! other networks commands all of them

! in area 25

!

this depletes the OSPF DB on the branch router and filters every network change.

Avoid to have the branch in area 0 that is the core of the OSPF domain.


Hope to help

Giuseppe


Amin Shaikh Mon, 12/01/2008 - 14:06
User Badges:

Thanks

In the HQ ; I already have

router ospf 10

network 192.168.0.0 0.0.0.255 area 0


now you want me to add in HQ the following

router ospf 10

network 192.168.0.0 0.0.255 area 0

network 192.168.1.0 0.0.255 are 25

are 25 stub


I have another company division where its more complicated


HQ is connected to 75 branches

at HQ its

router ospf 50

network 10.10.0.0 0.0.255.255 area 0


At branch-30

router ospf 50

network 10.10.0.0 0.0.255.255 area 0


int fa 0/1

ip address 10.10.30.0 mask 255.255.0.0


how could I configure ospf stub in this scenario

Joseph W. Doherty Mon, 12/01/2008 - 17:03
User Badges:
  • Super Bronze, 10000 points or more

"be aware that this doesn't stop OSPF hellos "


Misquote?


from: http://www.cisco.com/en/US/docs/ios/12_0/np1/configuration/guide/1cospf.html#wp5067


Configure OSPF over On Demand Circuits


The OSPF on demand circuit is an enhancement to the OSPF protocol that allows efficient operation over on demand circuits like ISDN, X.25 SVCs and dial-up lines. This feature supports RFC 1793, Extending OSPF to Support Demand Circuits.


Prior to this feature, OSPF periodic hello and link state advertisements (LSAs) updates would be exchanged between routers that connected the on demand link, even when no changes occurred in the hello or LSA information.


With this feature, periodic hellos are suppressed and the periodic refreshes of LSAs are not flooded over the demand circuit. These packets bring up the link only when they are exchanged for the first time, or when a change occurs in the information they contain. This operation allows the underlying datalink layer to be closed when the network topology is stable.


This feature is useful when you want to connect telecommuters or branch offices to an OSPF backbone at a central site. In this case, OSPF for on demand circuits allows the benefits of OSPF over the entire domain, without excess connection costs. Periodic refreshes of hello updates, LSA updates, and other protocol overhead are prevented from enabling the on demand circuit when there is no "real" data to transmit.


Overhead protocols such as hellos and LSAs are transferred over the on demand circuit only upon initial setup and when they reflect a change in the topology. This means that critical changes to the topology that require new SPF calculations are transmitted in order to maintain network topology integrity. Periodic refreshes that do not include changes, however, are not transmitted across the link.


Amin Shaikh Mon, 12/01/2008 - 22:16
User Badges:

Thanks Joseph.


ip ospf demand-circuit ( Its not clear how it gets updates and the time interval for updates; please if you can help me in understanding

Joseph W. Doherty Tue, 12/02/2008 - 04:12
User Badges:
  • Super Bronze, 10000 points or more

If I'm reading the documentation correctly, updates only happen during initial setup and as necessary thereafter. I.e. there is no time interval for updates when configured for on-demand.


Careful selection and design of topology OSPF topology can further reduce the need for updates, such as using OSPF stubs, as also mentioned by Giuseppe.

Giuseppe Larosa Tue, 12/02/2008 - 00:39
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Joseph,

thanks for having noted my mistake.


I was focusing on the fact that demand circuits can be useless if you keep the link in area 0 where it is exposed to every topology change.


from the same document you linked:


"Because LSAs that include topology changes are flooded over an on demand circuit, it is advised to put demand circuits within OSPF stub areas, or within NSSAs to isolate the demand circuits from as many topology changes as possible."


Best Regards

Giuseppe

Correct Answer
Joseph W. Doherty Tue, 12/02/2008 - 04:48
User Badges:
  • Super Bronze, 10000 points or more

Giuseppe, you're welcome, although I regret being the one to reduce your "batting average" to only .999 ;)


"I was focusing on the fact that demand circuits can be useless if you keep the link in area 0 where it is exposed to every topology change. "


Perhaps, but even within area 0, you might design a very stable area 0 topology if you have just area summary addresses and externals injected by statics. I.e., it might not always be useless even within area 0. However, it does make more sense, to restrict the technique to stub areas.


PS:

Amin, stepping back just a little, the real purpose for this technique was to avoid repeatly bringing up a dial-up/on-demand link for just routing hellos and avoiding toll charges, not so much to save bandwidth across the link when it was available. As Giuseppe also noted in his first post, OSPF maintenance bandwidth usage is low.


Careful OSPF design and tuning OSPF parameters can further minimize OSPF's bandwidth utilization (along with speeding convergence and increasing stability).


For your purposes, the real bandwidth savings of this technique is avoidance of periodic OSPF hellos (which don't use much bandwidth) or the periodic LSA refresh (bandwidth?), but unless you look carefully at your overall design, you could still have a lot happening when there is OSPF topology activity.

Actions

This Discussion