Speed/Duplex Settings

Unanswered Question

Beginning to integrate some of the 3560 gigabit switches in our infrastructure and have a question concerning speed/duplex. I know Cisco had always recommended hard coding speed/duplex vice auto on the earlier switches, but I thought I had heard that with the newer gigabit switches that Auto worked well with gigabit nics. Can anybody shed some light on this subject. Thanks Jr.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Tue, 12/02/2008 - 06:49
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Junior


Do you mean gigabit to client and servers rather than other switches. If so leaving them to auto-negotiate has worked well for me and is the recommended way to go.


Jon

k.cherian Tue, 12/02/2008 - 09:07
User Badges:

Hi Jr,

I agree with Jon. As long as the clients (End stations or Servers), have the nic cards configured for auto negotiation mode, they will jel along real well with Cisco switch Gig ports which also are configured for auto negotiation mode.


-/ KC

Joseph W. Doherty Wed, 12/03/2008 - 03:55
User Badges:
  • Super Bronze, 10000 points or more

This question is one that keeps arising.


With modern equipment, auto usually works as expected, so current recommendations appear to suggest its usage.


Older equipment, especially 10 Mbps ports, either didn't support auto or it didn't always work. This led, I think, to a lot of the history of avoiding it, especially for network to network device connections. Also, some network device ports were "late" in providing the feature compared to host systems.


On these forums, the general consensus, whether to use it or not, appears to be, yes for client hosts, usually yes for server hosts, but divided opinion between network devices. One argument for its continued usage between network devices is a link comes up just a little faster when hard coded.


Personally, I prefer auto everywhere unless I have a situation where I know it doesn't work correctly. This both to avoid the management hassle of some ports configured for hard settings and other auto, and to avoid people "forgetting" to reset port settings correctly when there is some type of device failure recovery where ports are repatched.


In the last several years, when I often run down extremely poor performance, it's often a duplex mis-match caused by one side being hard coded and the other auto.

Yes Joseph, I agree with you. The new Cisco switches using 1Gb seems to be able to take advantage of the auto setting better than some of the older switches. Our network staff, myself included, have been tossing this around since we are in the process of a complete infrastructure upgrade to get ready for VOIP. My experience when there is a performance issue is to look at the switch port to see if there are any CRC's or collisions, which usually indicate a speed/duplex mismatch. Like I said our desktop staff doesn't totally understand this issue even though we have discussed setting up pc's, printers, etc correctly. As for connectivity between network devices, I am using trunks and if I am correct they default to auto, thus they connect at the 1Gb. We will be going with 10Gb with our new equipment to connect VM servers and our edge switches for increased throughput.

Actions

This Discussion