Load Balancing over 2 ISP conncetions

Unanswered Question
Dec 3rd, 2008
User Badges:

Hi


I have 2 routers with 1 Mbps internet connection on each. Now I have to do the load balancing between these routers without any inetrnet load balancer.


Please suggest how can I achieve this ???

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
guruprasadr Wed, 12/03/2008 - 00:34
User Badges:
  • Gold, 750 points or more

HI Shiv, [Pls RATE if HELPS]


Load balancing is not possible in a multihomed environment with two ISPs. BGP selects only the single best path to a destination among the BGP paths that are learned from different ASs, which makes load balancing impossible. . However, load sharing is possible in such multihomed BGP networks.


Refer useful link below describing multiple scenario's of BGP environments:


http://cisco.com/en/US/tech/tk365/technologies_configuration_example09186a00800945bf.shtml


Hope I am Informative.


Pls RATE if HELPS


Best Regards,


Guru Prasad R

tajuddinmd Wed, 12/03/2008 - 00:54
User Badges:

Hi Shiv,


What WAN interface is your internet connection is and what is the routing protocol. ans also let your router model.


Taj

ariela Wed, 12/03/2008 - 03:03
User Badges:
  • Silver, 250 points or more

In this case another way to investigate, to load balance traffic with two or more ISPs, is the Performance Routing (PfR, named also OER, Optimize Edge Routing):


http://www.cisco.com/go/pfr


HTH

Andrea

dwtcp Wed, 12/03/2008 - 06:06
User Badges:

Hi all,

i have configured oer on a 2811 with two adsls over the same ISP.

Everything works fine BUT... ftp Sessions from inside to outside cannot open!!

Any ideas how to solve this?

here is my config:

LB_2811#

LB_2811#sh run

Building configuration...


Current configuration : 3310 bytes

!

! Last configuration change at 15:39:00 EET Wed Dec 3 2008 by dataways


key chain key1

key 1

key-string xxx

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

oer master

max-range-utilization percent 10

logging

!

border 213.140.137.188 key-chain key1

interface FastEthernet0/0 internal

interface Dialer1 external

interface Dialer2 external

!

learn

throughput

delay

periodic-interval 1

monitor-period 2

prefixes 200

aggregation-type prefix-length 32

!

!

oer border

logging

local FastEthernet0/0

master 213.140.137.188 key-chain key1

!

!

!

!

u

!

!

!

interface FastEthernet0/0

description ### Connected to ASA External ###

ip address 192.168.1.18 255.255.255.0 secondary

ip address 213.140.137.188 255.255.255.224

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface ATM0/0/0

no ip address

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface ATM0/1/0

no ip address

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 2

!

!

interface Virtual-Template1

no ip address

!

interface Dialer1

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

load-interval 30

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username XXXXXX

!

interface Dialer2

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

load-interval 30

dialer pool 2

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username XXXXXXXXX

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip nat inside source list NAT_Traffic interface Virtual-Template1 overload oer

!

ip access-list extended NAT_Traffic

permit ip host 213.140.137.189 any

permit ip 192.168.1.0 0.0.0.255 any

permit ip host 213.140.137.187 any

!

dialer-list 1 protocol ip permit



Actions

This Discussion