Is Voice VLAN supported under Trunk port on 3550????

Unanswered Question
Dec 3rd, 2008
User Badges:

"Voice VLAN is only supported on access ports and not on trunk ports, even though the configuration is allowed"


I can find this hints in cisco document for 2960/2970/3750 etc., however, i din't find it in 3550, so i'm wondering if voice vlan can be supported on trunk port on 3550?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Rob Huffman Wed, 12/03/2008 - 09:22
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Zhang,


This is a Cisco "best practice" on the older 3500XL Switches (like the 3550) the switchport mode trunk method was the only way to go, but on all newer versions (like the 2960/2970/3750)the need for Switchport mode Trunk is not necessary..


I do know that it is unnecessary to configure the switchport in Trunk mode because when you use the Voice VLAN (with a native vlan) command a "special" dot1q trunk is automatically setup. The reasons I have seen to support this setup are many and vary from minimizing Trunking overhead to ease of configuration and everything in between :)


Here is one of the better threads I have ever read on this issue (with some Tac links as well). There are some great answers from Mahesh,Paolo Sankar and others here.



http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddd5905/14#selected_message


Hope this helps!

Rob


zhangjianping Wed, 12/03/2008 - 09:47
User Badges:

thanks sir. 5 points for your kindness.


I'm preparing for the voice ccie lab with using 3550, in many materials regarding to voice vlan configure on 3550,it's under trunk mode, such as belowing way,

inteface f0/15

switchport trunk encapsulation 802.1q

switchport mode trunk

switchport trunk native vlan 4

switchport voice vlan 200


Whereas in my product environment with 3750, i used this way,

inteface f0/15

switchport access vlan 4

switchport voice vlan 200


SO, I'm just wondering if abovce configure is ok for 3550


BTW, in some scenarios, i don't want to change my native vlan from 1 to another, u know, I just want to use native vlan (vlan 1) for managent, and wang to use another vlan (such as vlan 4)for the PC's data traffic that attached in IPPHone jack

Rob Huffman Wed, 12/03/2008 - 10:15
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Zhang,


Yes, for the "older" XL models your config is just fine :)


Here is an old example from our lab;


interface FastEthernet0/12

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 10

switchport voice vlan 888

switchport trunk allowed vlan 1,10,888,1002-1005



Hope this helps!

Rob

zhangjianping Wed, 12/03/2008 - 21:10
User Badges:

Hi Rob,


according to your configure, Vlan 10 is native vlan, so I want to know which vlan u used for management ?


And, need I config on all the swetches to set vlan 10 as native vlan ?

Thanks

Actions

This Discussion