redistribute default route using ospf multiarea only in one area

Answered Question
Dec 3rd, 2008

Hi to all,

Is it possible to redistribute a default route using ospf multiarea just in one area??

For example if i have my area 0 for backbone and my area 1 for my locations can I redistribute a default route just to the area 1????

Thanks in advance

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 8 years 1 month ago

Hello Alfonso,

please do the following:

on ABR:

router ospf 10

no default-information originate always

no default-information originate

Some OSPF commands are tricky : if you make a single no the router just denies the always option and you need to give it a second time there is no other explanation for the O E2 default route still in area 0

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
thotsaphon Wed, 12/03/2008 - 09:30

hi Alfonso,

I'm not sure what you want. If you want all routers in area 1 to get only "default route". You can use "Totally Stub Area" in area 1. ABR will inject only default route to all routers in that area. It does protect LSA type 3 and 5 from being injected to that area.

Toshi

alfonso.cornejo Wed, 12/03/2008 - 09:39

Hi Toshi,

This is the scenario, I have my area 0 for backbone and my area 1 for my locations and what i need is that the routers that are in my area 1 plus knowing all the routes that the ospf process gives them also to have a default route given by ospf too, if i put the command default-information originate always the ospf process redistribute the default route to the area 1 but also to the area 0 and that's not what i need, i need the default route to be redistributed only in my area 1.

Thanks in advance.

thotsaphon Wed, 12/03/2008 - 10:25

Alfonso,

First of all, You are using "default-information originate always" that means no need to have a default route in RIB to advertise a default route. So Redistributing a default route is not needed. Your requirement is to filter LSA Type 5 (default information originate) to inject to area 0. I don't think that area filter-list commands will help you because it should filter LSA Type 3. As I mentioned above that would meet a requirement. But if this is a scenario to accomplish. Frankly I'm waiting for how it works... (grin)

Edit : if the requirements are allowed to use "distrition-list in" commands. I would apply it on all routers in area0 to get rid of a default route. It's not nice anyway!!

Toshi

Giuseppe Larosa Wed, 12/03/2008 - 11:21

Hello Alfonso, Toshi

if there aren't LSA type 5 external in the OSPF database a stub area satisfies all the requirements:

it receives all the OSPF routes (if no external routes)

it receives a default route from ABR router

I would consider this option.

Hope to help

Giuseppe

alfonso.cornejo Wed, 12/03/2008 - 12:12

Hi Giuseppe,

You mean that i should configure my area 0 as a stub area in order to not to get the default route redistributed by the ospf process??? and only the area 1 is going to get it...I'm I right???

Thanks in advance.

Giuseppe Larosa Wed, 12/03/2008 - 13:08

hello Alfonso,

yes the idea is :

remove the default-information originate

make area 1 a stub area

this makes ABR to automatically injects an O IA default router inside area 1

This is usually an acceptable solution: even if there are filtered external routes the default route allows to reach all prefixes known in the OSPF domain

Hope to help

Giuseppe

alfonso.cornejo Wed, 12/03/2008 - 13:31

Hi Giuseppe,

I did that, but in my routers where i just have area 0 I'm getting a default route given by my ABR O*E2 0.0.0.0/0 [110/1] via 172.16.1.1, 00:11:19, Serial0/1/0 and also in the routers that are in area 1 I'm having the default route that I want O*IA 0.0.0.0/0 [110/260] via 192.168.1.1, 00:08:35, FastEthernet0/0

But that default route on the area 0 is making me to have problems.

Config on ABR

router ospf 100

log-adjacency-changes

area 1 stub

network 192.168.2.0 0.0.0.3 area 1

network 192.168.3.0 0.0.0.3 area 1

network 192.168.5.0 0.0.0.255 area 1

network 172.16.1.0 0.0.0.3 area 0

!

ip classless

ip route 0.0.0.0 0.0.0.0 201.147.155.1

Config on a Location

router ospf 100

log-adjacency-changes

area 1 stub

network 192.168.1.0 0.0.0.3 area 1

network 192.168.4.0 0.0.0.3 area 1

network 192.168.6.0 0.0.0.255 area 1

Thanks in advance

Correct Answer
Giuseppe Larosa Thu, 12/04/2008 - 01:13

Hello Alfonso,

please do the following:

on ABR:

router ospf 10

no default-information originate always

no default-information originate

Some OSPF commands are tricky : if you make a single no the router just denies the always option and you need to give it a second time there is no other explanation for the O E2 default route still in area 0

Hope to help

Giuseppe

alfonso.cornejo Thu, 12/04/2008 - 11:45

Hi Giuseppe,

I did that and also restart the ospf process and it worked well, now I have the default route just on the area 1.

Thanks alot for your help!

Actions

This Discussion