Time on switch does not match logs??

Answered Question
Dec 4th, 2008
User Badges:
  • Blue, 1500 points or more

I wrote to memory so I would get a log entry and then I did show clock and the times do not match.....why would that be?

here is the output

Dec 4 14:42:21: %PFINIT-SW1_SP-5-CONFIG_SYNC: Sync'ing the startup configuration to the standby Router.

6509-VSS#show clock

09:42:37.656 EST Thu Dec 4 2008

6509-VSS#



Thanks mike

Correct Answer by Giuseppe Larosa about 8 years 7 months ago

Hello Mike,

I was meaning the following options


service timestamps log datetime ?

localtime Use local time zone for timestamps

msec Include milliseconds in timestamp

show-timezone Add time zone information to timestamp


I would add msec local-time


Hope to help

Giuseppe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (3 ratings)
Loading.
Giuseppe Larosa Thu, 12/04/2008 - 06:57
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mike,

it should be a question of timezone

in the service timestamps log datetime command there are options to move to another timezone


or the timezone is missing in NTP config you see that minutes and seconds are good enough


Hope to help

Giuseppe


burleyman Thu, 12/04/2008 - 07:10
User Badges:
  • Blue, 1500 points or more

service timestamps debug datetime

service timestamps log datetime

service password-encryption

service counters max age 10


clock timezone EST -5

clock summer-time EDT recurring


ntp clock-period 17083848

ntp source Vlan1

ntp master 10

ntp update-calendar

ntp server xxx.xxx.xxx.xxx

ntp server xxx.xxx.xxx.xxx

ntp server xxx.xxx.xxx.xxx

ntp server xxx.xxx.xxx.xxx

ntp server xxx.xxx.xxx.xxx


6509-VSS#show ntp status

Clock is synchronized, stratum 2, reference is 192.5.41.40

nominal freq is 250.0000 Hz, actual freq is 251.4051 Hz, precision is 2**18

reference time is CCE27041.178D5020 (10:05:37.092 EST Thu Dec 4 2008)

clock offset is -2.0895 msec, root delay is 35.89 msec

root dispersion is 10.45 msec, peer dispersion is 7.89 msec


Here is parts of the config....am I missing something? NTP looks correct.


Mike

Correct Answer
Giuseppe Larosa Thu, 12/04/2008 - 07:21
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mike,

I was meaning the following options


service timestamps log datetime ?

localtime Use local time zone for timestamps

msec Include milliseconds in timestamp

show-timezone Add time zone information to timestamp


I would add msec local-time


Hope to help

Giuseppe


burleyman Thu, 12/04/2008 - 07:29
User Badges:
  • Blue, 1500 points or more

Sorry....I understand now. It has been a rough couple days. Troubleshooting a high CPU % on this switch with no luck.


That worked... thanks.



Thanks,

Mike

Actions

This Discussion