LMS 3.1 - UT Dynamic Updates: Device Trap Configuration

Answered Question
Dec 4th, 2008

Hy experts.

When we try to configure MAC notification traps on a switch using the Device Trap Configuration tool of CM, there will nothing be configured on the switch.

The NetConfig job will be created and ends successfully. but in the CLS output you can only see that all interfaces are accessed in the configuration terminal, but nothing seems to be configured.

I've attached a copy of the report of the rme job.

Do you have any idea why this is happening and how we could fix that issue?

Thank you in advance!

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 7 years 10 months ago

This looks like my bug, CSCsv13860. What type of switch is this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
mwynen Fri, 12/05/2008 - 00:22

It's a Catalyst 2960. Does it belong to the C3560E class switches?

Joe Clarke Fri, 12/05/2008 - 11:17

There is only one 2960 switch type currently supported for automatic trap configuration (C2960-24-TC-S). The commands you need to deploy are:

mac-address-table notification

mac-address-table notification interval 15

snmp-server enable traps mac-notification

snmp-server host HOST version 1 COMMUNITY udp-port 1431 mac-notification

Where COMMUNITY is your desired trap community string, and HOST is the IP address of your Campus Manager server. Then, under each interface for which you want traps to be sent, configure:

snmp trap mac-notification added

snmp trap mac-notification removed

You can use Netconfig to do this.


This Discussion