LACP Suspended Port

Unanswered Question
Dec 4th, 2008

Hello,

I have found several conflicting articles on the internet on this subject, so here goes.

I have 2 ports on a 3750 in a LACP configuration. Both ports are switchports they are both identically configured with a "channel-group 3 mode active". They are connected to a Ubuntu (linux) box with LACP enalbled. One of the 2 ports in the bundle always goes in to suspended. it always seems to be the second one that is plugged in. like so:

EVPRODIDF05#sh ether sum

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port

Number of channel-groups in use: 3

Number of aggregators: 3

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SD) -

2 Po2(SD) -

3 Po3(SU) LACP Gi3/0/1(P) Gi3/0/4(s)

here is the lacp internal output:

EVPRODIDF05#sh lacp internal

Flags: S - Device is requesting Slow LACPDUs

F - Device is requesting Fast LACPDUs

A - Device is in Active mode P - Device is in Passive mode

Channel group 3

LACP port Admin Oper Port Port

Port Flags State Priority Key Key Number State

Gi3/0/1 SA bndl 32768 0x3 0x3 0x69 0x3D

Gi3/0/4 SA susp 32768 0x3 0x3 0x6C 0x5

I called TAC and the tech could not define why the port went in to suspended mode.

The ubuntu configuration seems to be sound as I can detect LACPDUs comming out of both ports on a port spann.

Any help would be apprecieated.

Thanks,

ed

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Thu, 12/04/2008 - 13:21

I would try using the interface range command and shut both those ports at the same time and then "no shut" the ports , i have seen where if you don't bring them both up at the same time ports will go into suspend mode.

gnijs Fri, 12/05/2008 - 04:05

Do you have to specify a VLAN ID on the Linux box ? (is the Linux box maybe tagging the packets ?) If so, you will need to convert the switchports to trunks.

Second, are you ports access ports ? Like this (please post the config of the access port):

int x/x

switchport mode access

switchport access vlan 1

channel-group 3 mode active

gnijs Fri, 12/05/2008 - 04:06

Do you have to specify a VLAN ID on the Linux box ? (is the Linux box maybe tagging the packets ?) If so, you will need to convert the switchports to trunks.

Second, are you ports access ports ? Like this (please post the config of the access port):

int x/x

switchport mode access

switchport access vlan 1

channel-group 3 mode active

specialed351 Fri, 12/05/2008 - 08:05

here are the configs. there is no vlan tagging on the linux box. the interesting thing is that when we did a packet capture on the nics on the server I saw lacpdu's comming out of the server but not the switch. even if I put the ports in active or passive mode. that just seems like the thing is broken somewhere.

EVPRODIDF05#sh run int g3/0/1

Building configuration...

Current configuration : 143 bytes

!

interface GigabitEthernet3/0/1

switchport access vlan 13

switchport mode access

speed 1000

duplex full

channel-group 3 mode active

end

EVPRODIDF05#sh run int g3/0/4

Building configuration...

Current configuration : 143 bytes

!

interface GigabitEthernet3/0/4

switchport access vlan 13

switchport mode access

speed 1000

duplex full

channel-group 3 mode active

end

EVPRODIDF05#sh run int po3

Building configuration...

Current configuration : 156 bytes

!

interface Port-channel3

switchport access vlan 13

switchport mode access

end

thanks,

ed vazquez

gnijs Sat, 12/06/2008 - 11:10

Try to disable fixed speed and duplex and enable auto-negotiation.

k.hariharan1 Mon, 07/26/2010 - 01:17

hi,

I am facing this same issue,  i had configured 3 links between 6509 to vmware server. among the 3 ports only one port is in use and the remaining 2 ports are going to suspended state. if i remove the cable from cisco switch which is in use, suddenly from the remaining two ports which is in suspend state one port come as it is in use (P). kindly let me know how  you had fixed this issue.

Regards,

Hariharan k

Actions

This Discussion