CUCM 7.x Subscriber Installation Fails

Unanswered Question
Dec 4th, 2008
User Badges:

Hi,


I am having enormous problems with something that was so simple in 6.x.


I have my CUCM 7.0 Publisher and I add the subscriber server on the publisher first. I configure DNS for forward and reverse resolution and validate this. I do the install and I get an error stating the subscriber cannot be validated by the publisher. Sometimes I get an unable to synchronize with NTP error even though the publisher is synched. I have tried without using DNS and still cannot install the subscriber. I had no such problems with 6.x.


Please helpe if you can.




Thanks,




Joey



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nunoscosta Sun, 01/18/2009 - 12:29
User Badges:

Hi Dewiele,


Did you solve your problem?


Regards,

Nuno

uddinabu1 Sat, 02/07/2009 - 15:32
User Badges:

I am having the same kind of problem during Subscriber installation.

Getting the error:

Unable to set the system clock using NTP server on the first node in the cluster...

any idea......


thx

nunoscosta Mon, 02/09/2009 - 13:07
User Badges:

Hi,


Are you in lab scenario or real scenario?


I am using vmware :(

I did not solve my problem yet...




j.dewiele Mon, 02/09/2009 - 13:22
User Badges:

Same here and I have not solved my problem yet either.

Tommer Catlin Mon, 02/09/2009 - 15:55
User Badges:
  • Green, 3000 points or more

I had a CUCM 7.0 using a windows server for an NTP source and it totally screwed up the Subscriber on install. It never really worked. I had re-install the subscriber and change the NTP source on the publisher to an IOS switch or external. Once that was taken care, it worked fine

uddinabu1 Tue, 02/10/2009 - 05:49
User Badges:

I am using VMware for Cisco UCM7.0 and also my NTP is IOS router (external HQ Router).I see publisher is synchronized with NTP but interesting few minutes behind (8-12mins).


Any idea


Thx for help

limyuensan Thu, 02/12/2009 - 00:43
User Badges:

I had tried that but it still didn't work for me.


I had changed the NTP source on the publisher to an external router (configured as the NTP master) and re-installed subscriber.

uddinabu1 Thu, 02/12/2009 - 05:58
User Badges:

Hi Limyuensan,


Any idea why my config is not working? or provide me your configuration steps(details)how you successfully installed subscriber? On MCS Server(real hardware) subscriber installation is working fine without any issue(tested) but I am using vmware at my home Lab and giving problem.


Thx

limyuensan Thu, 02/12/2009 - 17:43
User Badges:

Hello,


I think this problem seems to be unique to installations using VM. As indicated in other forums, many have faced the same issue.


Mine is a lab environment.


My installation of the subscriber in VM is still facing the issue of not being able to synchronize with the NTP in the publisher.


I have set my publisher to sync with an external router which I have configured as a master NTP. The pub sync for a moment but thereafter lost that sync and started following its own clock. I notice when this happens, if you install the subscriber, it fails.


My other routers are able to sync with the master NTP router. I have tested and eliminated connectivity issues.


According to one of the posts here, the sub should install successfully if the pub is sync with an external NTP. That post, though, did not specify whether the installations were done on an MCS or VM.





panjwani80 Fri, 04/17/2009 - 21:31
User Badges:

Hi All,


did anyone manage to fix this problem? i am running CUCM 7.0 on Vmware ESX 3.5. Subscriber installation is failing to validate the publisher even though i added the subcriber server on the publisher first. i am using local hardware clock on publisher.


Any help would be highly appreciated


Thanks

j.dewiele Sat, 04/18/2009 - 03:13
User Badges:

Hey,


No luck here at all.


I guess you can only do som much with VMWare.

Christopher Lunsford Sat, 04/18/2009 - 19:45
User Badges:

I am running into exactly the same problem. Has anyone had any luck with adding a new subscriber on VMware?


Thank You!

Chris

kinwai Sun, 04/19/2009 - 06:20
User Badges:

i didn't face any problem when install on both vmware server/workstation series and ESX series.


I guess the problem is the pub/sub communicate using ipsec. When the time is out of sync by far too much, the installation will fails.


In vmware server/workstation series, the time lose sync very fast even it's sync to ntp due to some vmware limitations. To solve this, just use vmware ESX instead.


Therefore the answer to the problem is after installing pub, asap try to install sub before the time difference is too great or adjust the pub's bios to the actual time before you start installing the sub.

uddinabu1 Mon, 04/20/2009 - 04:57
User Badges:

At the end I am able to install ccmpub and ccmsub on vmware!

What I am using:

- Windows 2003 server Enterprise OS

-vmaware server 1.4

- add ccmsub on the ccmpub as per cisco docs

-make sure NTP is synchronised, verify with command "utils ntp status" on ccmpub CLI

-SUCCESS

Thanks

sevaitment Sat, 07/18/2009 - 05:02
User Badges:



After having the same NTP sync problem other posters had, I did some investigating.


One of the component checks of the NTP scripts called "slew" was failing and I determined that this could not be overcome by changing any setting in the install process.


There would be much more complaints if everyone was having this problem and I wondered if VMware itself could be the culprit. So, I switched VMware products and attempted to install the Subscriber again. It worked flawlessly.


I can confirm that VMware Server version 1.x.x is the source of the NTP sync problems.


I am assuming one possible reason is because of the outdated driver for the Virtual Ethernet Adapter. It hasn't been updated in 5 years.


The product that did work, VMware Workstation (I used v6.5), has an updated driver. VMServer 2.0 also has the same driver version but I was not able to test it for an unrelated reason. My host OS is Windows Server 2003.


There has been conflicting information in this thread, and in other forums, about what works and what doesn't. Most posters didn't explicitly state what versions of VMware they were using which contributed to the confusion. Perhaps this information will help those that are still having NTP sync problems.



uddinabu1 Mon, 07/20/2009 - 04:53
User Badges:

Hi,

Is this (VMware Workstation v6.5)free download? if not how I can find!

One more thing, I found out CallManager PUB/Sub Register with Gatekeeper but few minutes they unregister( I am using Vmware server 1.x), please test in your lab with vmware workstation 6.5 and let us know.


thx

Actions

This Discussion