COBRAS Import Problem

Unanswered Question
Dec 4th, 2008

Hello,

[I have the exact same post as this one and if you see that post, please just ignore it. I accidentally created it twice]

Here's the issue:

I used COBRAS to back up a test user on a one forest that houses Unity 4.x w/ Exchange 2003 off-box and imported it to another forest that contains Unity 5.x w/ Exchange 2007. Everything appears to go through alright. But I don't see that user from the SA. I even tried to create another brand new test user, did the same thing to restore and still not seeing the imported user in SA.

Could someone please explain to me if I've done anything wrong here?

Thanks,

Kevin Tran

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ktran-anet Tue, 12/02/2008 - 00:52

Yes sir, I am absolutely aware of that when I implemented Unity 5.x with Exchange 2007. FYI, those test subscribers already exist in the new forest and to verify that I could import them 100% successfully from the SA if I would choose to. However, I don't want to do that because we have more than 5 hundred users that need to be moved over to the new forest and we want to keep all their personal settings as much as possible.

Thanks,

Kevin

ktran-anet Mon, 12/08/2008 - 12:35

FYI, after I did the Cobras import, I went to the SA and did a subscriber search. As you can see from the attached .bmp file, I can see a test user called UnityTest01 in there. But when I double click to open that user, it doesn't show me that user's profile. Instead, it's showing me the Example Administrator's profile.

ktran-anet Mon, 12/08/2008 - 12:09

Thanks for your response. I did the same but I didn't work for me.

Tommer Catlin Mon, 12/08/2008 - 12:42

You should probably check to ensure your new Unity 5.x is actually working with Exchange 2007.

Create a new user in AD with and Exchange 2007 mailbox.

Import the user on the SA page to Unity.

Verify you can leave a message, retrieve a message, MWI works, etc.

Once completed, then try again.

ktran-anet Mon, 12/08/2008 - 12:49

Oh yeah that will work like a champ. Please read my replies above.

lindborg Mon, 12/08/2008 - 16:17

Error in the log says it all:

(error) maximum amount of time waiting for directory sync to complete has been exceeded - skipping messages for this subscriber.

you have a directory synch issue - dimes to dollars that SQL entry for the user you're importing does not have a DirectoryID. This would explain why the SA shows the default (first) user in the database instead of that user when you go to view them - that's how the SA works. Short version is COBRAS is not invovled here (it does not ever make directory connections and, in fact, is not aware of what back end Unity is connected to). It sets up the SQL information and then asks Unity to synch that user. This is failing.

The next step is to look at the SQLSyncSVrxxx log (in the Unity logs folder) which will have more information about what's failing on the sync. But in general you can take COBRAS out of the suspect list - it's not doing anything magical here. If the synch is failing you need to investigate that end of it before doing anything else.

ktran-anet Mon, 12/08/2008 - 20:25

Hello Jeff,

Thanks for looking into this. What would be the cause of directory sync issue?

I looked at the sqlsync.txt as per your advice but it makes no sense to me.

Failed getting alternate extensions for user unitytest01. \DbSync.cpp (line 763)

ERROR: Skipping subscriber unitytest01 - existing directory user must have a mailbox 0x800b1006 \DbSync.cpp (line 797)

I'm positive that it has a mailbox and a valid extension. I have attached the full log here. So could you please take a look and advise? Do you know if Cisco has any document addressing this kind of issue?

Thanks,

Kevin

Attachment: 
Tommer Catlin Tue, 12/09/2008 - 09:00

AD issues or Unity have an issue talking to the AD. Go into DC/GC reconnect and test that it is connected.

Test Connection

Go into Application log

You should see Unity create a log for attempting DC connection

Then another log that Unity has completed a completed full sync. If a full sync does not happen, there is some kind of AD issue or DNS going on.

Markus Schneider Fri, 12/05/2008 - 05:24

Did the AD account and mailbox already exist in the Unity5/Ex2007 forest? For Exchange 2007 integrations, COBRAS (or Unity for that matter), cannot create the user. It can only be imported. So COBRAS needs to be able to bind to an existing AD account and mailbox and create (e.g. import) the subscriber from there.

The help file mentions this:

"Caution! If the partner Exchange server is running Exchange 2003 or Exchange 2000, Cisco Unity can only create accounts in Active Directory if, when you ran Permissions Wizard, you chose the option to create users using the Cisco Unity Administrator. If you did not choose this option when you ran Permissions Wizard, the COBRAS restore will fail because AD accounts cannot be created. With Exchange 2007 all users and DLs must exist in the directory ahead of time since there is no “on the fly” object creation supported at this time."

from:

http://www.ciscounitytools.com/Applications/COBRAS/Help/COBRAS.htm

Actions

This Discussion