QOS - Packet Drops in Default-Class

Unanswered Question
Dec 5th, 2008
User Badges:
  • Gold, 750 points or more

Hello Experts,


Below is the Standard QOS Configuration applied for my Major Customer. The recent complaint is, the Customer is experiencing the PACKET DROPS for the normal packets that are NOT classified, since they are preferring the default-class.


Request your Help/Advice in advance.


policy-map Customer-A

class class-default

shape average 256000

service-policy Customer-Child


policy-map Customer-Child

class Cust_class_EF

bandwidth percent 50

class Cust_class_AF

bandwidth percent 30

class Cust_class_AF1

bandwidth percent 20


class-map match-all Cust_class_AF

match ip dscp cs4

class-map match-all Cust_class_EF

match ip dscp ef

class-map match-all Cust_class_AF1

match ip dscp 29


interface GigabitEthernet0/3.123

description ***Customer-WAN**

encapsulation dot1Q 123

ip vrf forwarding 2000-Customer-MESH

ip address xx.xx.xx.xx 255.255.255.252

service-policy output Customer-A

end


Thanks.


Best Regards,


Guru Prasad R



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joseph W. Doherty Fri, 12/05/2008 - 07:57
User Badges:
  • Super Bronze, 10000 points or more

Well you've defined 100% across all your named classes within the policy-map Customer-Child. This doesn't leave any reserved for the implicit class-default. (I'm surprised this policy is accepted since normally you shouldn't be able to define more that 75% unless you override the default 25% other traffic reservation, and I don't see that being done within your interface config snipet. Perhaps this policy is accepted because it's a subordinate policy.)

Actions

This Discussion