VPN Client 5.0.04.0300 - Start Before Logon Issues

Unanswered Question
Dec 5th, 2008

PC Info: Panasonic CF-30 ToughBooks. XP SP3. Connection is Sprint Mobile Broadband Express Card Merlin EX720 by Novatel Wireless. VPN Client version 5.0.04.0300 upgraded from version 4.8.00.0440

We need the VPN logon screen to appear before the windows logon. With v4.8 it worked fine. It actually seemed to “wait” for the card to connect then display the logon box. With v5.0 it does not. The client acts as if it is trying to connect without waiting for the Sprint card's connection to be established then throws an error message. The message is generally “Reason 427: Unknown Error Occurred at Peer” or a similar message. If I go to the minimized status box and press Connect, I get a connection dialog and can log in normally.

Obviously I have the “Enable start before logon” box checked. I also have the “Allow launching of applications before logon” to hopefully allow Sprint's dialer to connect fully. I have checked the documentation I could find for anything that could be added/changed in the VPN's setup files. The closest thing I could find adding an entry in vpnclient.ini is to add DialupWait= and the number of seconds. I've tried 1, 5, and 10 but the client seems to throw the error message at exactly the same time, like it isn't reading the .ini at all. And yes, Sprint is set to load and connect at startup also.

Is it possible to set the client to be the absolute last thing to load before the logon screen appears? Possibly configure it to actually wait to detect a connection before it throws the error? Are there any issues with this model of Sprint card that appeared with the latest version?

On a side note, how can I suppress all the error message windows that it throws now? I don't mind clicking buttons but a majority of our users do not have the time or patience to be clicking through them. When they use the laptops, they need to get on and get going ASAP.

I realize a practically wrote a book here but that's the situation. If there is actually something else you need to know to help with this issue, let me know.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
carenas123 Thu, 12/11/2008 - 10:05

Error 427: unknown error occurred at peer.

This error can only occur when you are trying to set up a VPN connection on top of a wireless connection and the LAN cable is not connected.

In that case you have to disable the 'regular' LAN connection. For this purpose go to the control panel (in classical view) - network connections and then make a right-click on the LAN connection and click "disable" (NOT the LAN for the Cisco Client but the LAN for the ethernet card) and select "disable". Please note, if the computer has to able to connect over an ethernet/utp cable, the LAN connection has to enabled again.

Actions

This Discussion