Please help! Switch 3550-48!

Answered Question
Dec 6th, 2008

Hi all!

Could you please help me on my cisco switch problem?

My switch prompt shown below:







How could I restore my switch back to working condition? I have an IOS image but don't know how to restore from this level.

Your help is very much appreciated.

Thank you very much in advance.

Best regards

I have this problem too.
0 votes
Correct Answer by viyuan700 about 7 years 10 months ago

can you format the flash and see if works

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
royalblues Sat, 12/06/2008 - 01:02

The switch image seems to be corrupted.

try the following commands on the prompt



After this do a dir all and see whether u see any IOS file in the flash. If there is none proceed to X-modem image transfer

Have a look at this link


sannymlao Sat, 12/06/2008 - 01:55


I followed your instruction and got an error message as shown below:

The password-recovery mechanism is enabled.

The system has been interrupted prior to initializing the

flash filesystem. The following commands will initialize

the flash filesystem, and finish loading the operating

system software:



switch: flash_init

Initializing Flash...

flashfs[0]: unable to allocate available block.

...done Initializing Flash.

Boot Sector Filesystem (bs:) installed, fsid: 3

switch: load_helper

switch: boot

Loading ""...: permission denied

Error loading ""

Interrupt within 5 seconds to abort boot process.

Boot process failed...


What I'm going to do next? Did you notice the prompt after switch? It's colon instead of prompt.

Thank you for your reply.

Best regards

sannymlao Sat, 12/06/2008 - 02:13


Here's the result of DIR as shown below:

switch: dir

List of filesystems currently registered:

flash[0]: (read-write)

xmodem[1]: (read-only)

null[2]: (read-write)

bs[3]: (read-only)


What's next?

Thank you very much.

Best regards

royalblues Sat, 12/06/2008 - 02:16

dir flash:

could you please read through the link provided in the previous post which will guide u in recovering the switch


sannymlao Sat, 12/06/2008 - 02:36


I followed instruction very carefully and got a message:

"Transfer cancelled by remote system".

Even I did not touch anything from the keyboard.

What do I do next?

Thank you for your prompt reply.

Best regards

viyuan700 Sat, 12/06/2008 - 07:14

u get this message when in protocol field u dont choose xmodem.

In send file prompt after choosing the IOS file remmeber to choose xmodem.

I think that will fix ur problem

sannymlao Sat, 12/06/2008 - 21:26


I choosed xmodem before clicking the send button.

Thank you for your reply.

Please anyone out there can provide a solution on this one?

Your help is very much appreciated.

sannymlao Sun, 12/07/2008 - 03:14


Thank you for your reply.

No problem, I can format the flash. But, since this my first time to format a flash, can you give me the safest procedure to do that first thing first? I don't like the problem to become worst or system unusable.

Once again thank you very much for your reply.

Best regards,

sannymlao Sun, 12/07/2008 - 03:49


It's currently copying ios after formatted the flash. I'll return to you when finished (shows 3.5 hours to finished) to give you the result.

Thank you for your reply.

Best regards

sannymlao Sun, 12/07/2008 - 21:57


Thank you very much for your reply.

Now, it works by reformatting the flash.

viyuan700 Sat, 12/06/2008 - 01:21

if you have an IOS image on the switch try boot flash:(image name)at this switch prompt

Before giving you this switch prompt is it give you message that cannot load/find IOS something. you can paste that file name after flash: or u can see dir flash:to get the file name

If u dont have IOS or the current IOS on the switch is not working then u have to transfer through xmodem as mentioned in the other post


This Discussion