Help with NAT

Unanswered Question
Dec 7th, 2008

I just got my DSL working on my new 861, but can not get the NAT working. I had it working before when I was testing within my network, but I can't get it to work while it is online with my DSL connection. The DSL is using PPPoE. Everything is working but the NAT. I have also attached the current running config.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jon Marshall Mon, 12/08/2008 - 03:31

How have you verfied NAT is not working - can you try connection and post output of

"sh ip nat translations"

Also can you post output of "sh ip route"

You have "ppp ipcp route default" in your config which i have never used. Could you try adding

ip route Dialer0

and retest.


webmastadj Mon, 12/08/2008 - 14:25

Ok, did what you said. The IP ROUTE didn't have effect. I was still able to get online and such. I have attached the output from the show commands.

webmastadj Mon, 12/08/2008 - 18:01

I have tried everything it seems like. Even rebuilding the config.

ajagadee Mon, 12/08/2008 - 20:49


Which part of NAT is not working. I can get to your web server with the ip address in the NAT Translation that you had posted. That is, So, to me looks like NAT is working, atleast the web server part.



webmastadj Tue, 12/09/2008 - 04:26

NAT is not working on the CISCO router at all. The reason why you can get to the site is because I have a linksys router, which I am replacing with the CISCO, and has all the ports open I need (80, 443, 21, 23, etc). I can't just leave my server off-line so when I am done testing the CISCO, to revert back to the linksys.

Giuseppe Larosa Tue, 12/09/2008 - 00:13


try to add a second PC with ip different then 192.168.x.3

and see if you can access internet from it.

your local web server should be working correctly as you can see in the sh ip nat translations there are few accesses to TCP port 80.

Hope to help


webmastadj Tue, 12/09/2008 - 04:34

I know the server is working, if I go to localhost on the server or type in its IP address, it takes me to the test page.

I had the it working before, when I just was using the CISCO router inside my linksys network. Staticly assigned the IP address on the WAN (fa4), and it worked. But with the DSL and PPPoE, it doesn't.

I have looked everywhere it seems like, and I believe my NAT config is correct. Tried changing the dialer from di1 to di0, still no good. Tried reassigning the ip nat outside to fa4, didn't work. Tried multiple different styles of access lists and nat tables, none worked. For what I see, it should be working. Even tried telneting to port 80, doesn't go through.

Again, the laptop I have inside the cisco network is able to go online with out a problem.

webmastadj Tue, 12/09/2008 - 15:45

Still no more ideas? I would like to get this working before the end of the week. I know it has to be some command somewhere that I am missing.

webmastadj Thu, 12/11/2008 - 17:29

I found the problem. It was with the Access-list and my test computer. The test computer was programmed with the wrong Default Gateway. Also, the access-list was allowing 80 on when it was supposed to be

That is all, thanks for you alls help.


This Discussion