Device discovery

Answered Question
Dec 7th, 2008
User Badges:

I have tried discovering the devices using the seed device and also the IP range but to no avail. All the devices have cdp enabled but no SNMP configured.


The discovery report shows that the seed device is unreachable yet I can ping the seed device from the LMS server.


What could the issue be?


Correct Answer by Joe Clarke about 8 years 7 months ago

Your seed device is 10.3.14.5, but your discovery filter is only set to discover 10.1.1.1. Try relaxing the filter so that the nodes you want to discover are allowed.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Sun, 12/07/2008 - 23:42
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Without SNMP, discovery will not work. All aspects of LMS require SNMP (at least read-only SNMP) to be configured on the devices. If you configure a read-only community string on all your devices, then configure that same string in Discovery SNMP settings, then Discovery will find them as reachable.

anthony_m Wed, 12/10/2008 - 01:41
User Badges:

I now have two devices configured with SNMP but still cannot discover the devices. I keep on getting the error "No devices discovered".


Please find attached the screenshot from device center showing that with SNMP the device is reachable.



Joe Clarke Wed, 12/10/2008 - 09:36
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post your NMSROOT/campus/etc/cwsi/DeviceDiscovery.conf.

anthony_m Tue, 12/16/2008 - 07:04
User Badges:

That specific file does not exist in the directory. Is this a problem?

Joe Clarke Tue, 12/16/2008 - 08:11
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Sorry, I mixed Campus Discovery and CS Discovery. The file is NMSROOT/campus/etc/cwsi/DEviceDiscovery.properties.

Correct Answer
Joe Clarke Tue, 12/16/2008 - 22:09
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Your seed device is 10.3.14.5, but your discovery filter is only set to discover 10.1.1.1. Try relaxing the filter so that the nodes you want to discover are allowed.

Actions

This Discussion