CSDiscovery is not a registered server name

Unanswered Question
Dec 8th, 2008
User Badges:

Hi all,

I have the following issue with Device Discovery under Common Services 3.1.1 :

When i start discovery, it never ends. In the CSDiscovery.log it logs :

[DiscoveryJobUtil : processStatus] : ErrorStream Line: ERROR: CSDiscovery is not a registered server name.Please enter a valid process/server name or check the case of the entered process/server name.


Restarting the LMS does not help

Any suggestions? I've attached CSDiscovery-config.xml



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 12/08/2008 - 09:21
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post the output of the pdshow command. It sounds like the LMS 3.0.1 update was not properly installed as this service should have been registered.

Velin Georgiev Mon, 12/08/2008 - 22:43
User Badges:

Hi Joe,

Here is the output of pdshow command attached

It seems to me that all processes are in state that are suppose to be...

Should I re-install the update?



Joe Clarke Mon, 12/08/2008 - 22:51
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I don't see any other process state problems. However, CSDiscovery is missing. Try doing a reinstallation as local Administrator after disabling anti-virus software, and setting the TEMP and TMP environment variables to short values (e.g. C:\WINDOWS\TEMP).

Velin Georgiev Wed, 12/10/2008 - 01:33
User Badges:

Hi Joe,

I tried to reinstall after setting the environment variables as you said.

I still can't see the CSDiscovery process in the process list of Common Services and i get the same error as described in my first post.

I'm not quite sure if this is related to the problem, but i noticed a file in the NMSROOT directory with a name DiscoveryLock and content "DiscoveryLock to avoid the discovery two preocess ". I have attached the pdshow output again



Joe Clarke Wed, 12/10/2008 - 09:33
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post the latest Ciscoworks_install log under C:\.

Joe Clarke Thu, 12/11/2008 - 07:38
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I don't see any errors here. Try running this command as a local Administrator with Daemon Manager running:


pdreg -r CSDiscovery -e C:\PROGRA~1\CSCOpx\bin\cwjava.exe -f "-cw C:\PROGRA~1\CSCOpx -cw:jre lib\jre -cp:pmf conf\csdiscovery\CSDiscovery.mf com.cisco.nm.csdiscovery.CSDiscoveryManager" -n

Velin Georgiev Fri, 12/12/2008 - 06:17
User Badges:

Yep, the command execution was succesful. Now i can see the CSDiscovery process in the processes list.

And i started a discovery to see if it works fine.


I'm curious what exactly was the problem and why it happened, if you don't mind to explain in brief


Thank you for your cooperation

Have a nice weekend

Joe Clarke Fri, 12/12/2008 - 08:48
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I don't know. The log did not indicate why CSDiscovery was not registered.

Actions

This Discussion