High circuit utilization and WAAS

Unanswered Question
Dec 8th, 2008

We have been experiencing some issues that I think are related to the WAAS and need opinions and advice on how to resolve.

We are running the latest 4.1.1c code on all WAEs and are running in the new AO mode (not file services in legacy mode).

At our data center (where the servers are) we have a 9mbps circuit connecting it to the MPLS cloud. At some of our remote sites (where the users are) we have T1s and fractional T1s. Almost daily we are seeing cases where a single connection is consuming all of the bandwidth at the remote sites. This is typically only for a defined period of anywhere from 10 minutes to an hour and can be traced to particular activity like copying a large files, etc. Before the WAAS was implemented we wouldn't see cases where a single operation could consume literally 100% of the bandwidth and I wonder if the core WAAS (at the data center) could be over utilizing the bandwidth since the core has 9mbps available.

The problem is that when this occurs, it affects everyone else on the circuit since the circuit is slammed. Most of our users use terminal server connections and theses are greatly affected when all of the bandwidth is consumed. We have given the terminal server connections a higher priority inside the WAAS (through policy prioritization) and setting the DSCP marking to af21(18). We have even tried QOS on the routers but the condition occurs on a regular basis.

Please help!

David

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ropethic Mon, 12/08/2008 - 11:01

Go to devices -> edge wae

configure -> acceleration -> tcp adaptive buffering settings

If enabled, try disbaling with default settings.

the adpative buffering option will tr yand utilize the link as efficiently as possible given the BDP (bandwidth x delay)

dkennedy99 Mon, 12/08/2008 - 12:52

When you say disable with default settings, do you mean leave the numeric values alone in the "Send buffer size" and "Receive buffer size" fields after unchecking the "Enable" button?

I am using NME-502's at my edge sites which defaults to 512KB.

I have one edge site that is a 612 and my core site is a 612, both of which default to 4096.

dkennedy99 Mon, 12/08/2008 - 13:32

The range that my devices give is 0 to 8192KB.

So you are saying to set the edge(s) to 8192KB and the core to 32KB??

That seems vastly different than the existing 512KB on the edges and 4096KB on the core that it is currently.

Please confirm this.

ropethic Mon, 12/08/2008 - 15:10

See the attached. It provides a very good overview. Is the adaptive buffering enabled?

If not, either way a TCP window of 512K allwos the WAE to burst segments upwards to 512Kbytes. You want to be able to utilize the link to maximum capacity to compensate for latency. Howeve rif smaller apps are being choked then need to be adjusted. I am suprised that Q0S on the router had little effect ont he smaller traffic sessions.

Richard Bradfield Mon, 12/08/2008 - 18:54

I have a very similar network to yours, I find the only way to really control o/p is by using policy maps and QOS on the router interface to control how much bandwidth is allowed to each remote site

Actions

This Discussion