CUPC Soft Phone Mode

Unanswered Question
Dec 8th, 2008

I have a lab enviroment that I have installed UCM 7 UC 7 and CUP 7...all seems to be working fine but I can't change the phone mode to Soft Phone. The server health shows Soft Phone grayed out and Not in Service. I have added the device with the same ext. as a Cisco Unified Personal Communicator device and the Device name is UPCJOEHARBISON ...user is associated with device and all user id / device are associated with the device. Desktop control works fine. Device in CCM never shows registered (don't know if should). I have found many documents that have said the device name is UPC<User ID> but some say 12 digits some say 9...some say to allow CTI some say to not...could this be a sip issue if all other items such as line state are working? Any help would be appreciated...I am getting frustrated...

Thanks,

Joe

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
joeharb Tue, 12/09/2008 - 07:03

Update:

Looking @ the log file on the client PC I see: 2008-12-09 08:55:32,218 [0x00000e74] INFO LCMiddleware - (MWMSG_CFGMGR_LICENSING) ConfigurationManager: licensing =

Presence = yes

Softphone = no

Video = yes

IM = yes

What could cause this?

j.mccartney Tue, 12/09/2008 - 14:52

I resolved a similar issue by going into user-management-->end-user and making sure under the Device Associations that the "UPC-device name" is in this window. HTH's

j.mccartney Tue, 12/09/2008 - 14:56

also make sure the licensing has check marks for it under CUCM --> System --> Licensing --> Capabilities -->"user" has 2 checks mark for enable CUP and enable CUCP.

HTH's

joeharb Wed, 12/10/2008 - 05:54

The device is listed under the Device Associations and both items are checked under the license capabilities. I have racked my brain on this one...Just so I am clear I don't have to install the softphone...it is part of cupc install.

Joe

joeharb Wed, 12/10/2008 - 08:17

Also just to make sure I am clear...the UPC devices should be UPC with upto 12 characters? Also should these devices show registered within CallManager if they are connected?

Thanks,

Joe

joeharb Thu, 12/11/2008 - 08:57

I am still stuck...I don't think it is a sip issue since I get presence onhook/offhook updates. Do you have any suggestions of where I can look to determine what is going on..debuggin of the client is not much help since it simply states softphone = no ...

Thanks,

Joe

j.mccartney Thu, 12/11/2008 - 15:26

OK, maybe I missed something you said so when you have a UPC client up and go to Help --> Show Server Health - you should see the options in CUCP and the softphone is red? What if you click under this same window where is has the "Softphone" option under "Server:" what msg do you see in the right side of the screen?

j.mccartney Thu, 12/11/2008 - 15:32

Do you see something like in my attachment here? Also, go to your Presence server log in as the admin and then go to Application --> Cisco Unified Personal communicator --> User setings --> find the one you want to get working do you see a screen shot similar to attachment titled "Presence-user-setting"?

j.mccartney Fri, 12/12/2008 - 07:23

Hi Joe,

We have CUCM6.1, CUPS6.0 and Unity 7.0. You may be right about the different versions.

joeharb Tue, 12/16/2008 - 06:38

I have looked @ the config file I download from the server...UPCJOEHARBISON.cnf . Everything looks good in there, I have made changes to the UPCdevice and restarted the Communicator and the changes are reflected in the config file. This seems to be something very simple but I almost lost..I have completely reinstalled precence. Changed users Capabilities and added them back. Still stuck without a soft phone in the CUPC, Odd that it tells me Softphone Not Active in the server health...I noticed your setup has a SIP proxy profile..I can't find that in the User setting on 7.X...anyone else know where to look for the user specific sip values...

Thanks,

Joe

scott.searle Fri, 12/19/2008 - 12:49

My issue with phone control was related to the ACL configuration. Have you verified the inbound and outbound ACL on your presence server?

joeharb Fri, 12/19/2008 - 13:40

Yes,

I have created an inbound and outbound acl for 'all' ...I have no problem with the desktop phone controll, I simply can't get the soft phone to be available...don't know if this is a licence issue or what..as I have said the device licences used for this are applied and the capabilities of the user are set...but in the log file I get a message that states soft phone = no ...this is a lab box so no acutal licence files have been applied...I would think that was the issue except that all other functions work.

Thanks,

Joe

bmcghee Sat, 08/08/2009 - 10:17

HI Joe, you ever find the resolution to this issue? I'm running into the same issue...Thx!

joeharb Mon, 08/10/2009 - 05:11

No, I pretty much dropped it. I have not worked with the presence feature in some time. We have current installation that will be implementing presence. this will not be a vm installation so I hope to have better luck.

Thanks,

Joe

htluo Mon, 08/10/2009 - 06:16

Some info regarding CUPC softphone mode:

1) You have to follow naming convention, which means the device name in CUCM has to be UPCUSERID. If your USERID contains special characters or longer than 12 characters, it might or might not work depending on CUPS version.

2) You don't have to associate this device to end user. Though it won't do any harm.

3) DN configured on softphone as to match the "Primary Extension" configured in CUCM > User Management > End User page.

Hope this help.

Michael

http://htluo.blogspot.com

Tommer Catlin Wed, 03/31/2010 - 12:07

Hi Michael -

What the UPC name is longer than 12 characters or 15 total?  Can I simply use the first 12 and it will or?  It will be CUPS 7.05

Thanks much!

htluo Wed, 03/31/2010 - 14:20

Yes, you can simply use the first 12 characters.

BTW, on CUPC 8, there's no requirement that the device name has to contain user ID.  The relationship was established by CUCM device association on end user page.

Michael

http://htluo.blogspot.com

Tommer Catlin Wed, 03/31/2010 - 14:23

Thanks Michael!  Thats what I thought, just wanted to double check.

Nice to see in 8.0 to see it associated to the username.

Cheers! (great q&a also)

BSILA OMAR Sat, 07/03/2010 - 05:17

Hi joe,

have you found a solution to this issue? I have the exact same issue and I think configuration is ok (UPCuserID, primary extension, the tftp file is loaded and OK but on the CallManager it is showing unknown as a status and as an ip address)

Regards

Omar

Actions

This Discussion