What's wrong with my little Hunt Group

Unanswered Question
Dec 9th, 2008
User Badges:

All I want is after 15 seconds of searching through the Hunt Group for it to go to voicemail. For some reason this has become difficult. Right now when I call the hunt group it will seemingly go on forever and never actually go into voicemail like it should. Here is the script in text and I've attached the actual aef file as well. The 993991 is the voicemail, I put in a translation pattern for 99 to be * so it goes straight to voicemail. It works fine outside of the script, and again it doesn't appear that it's even trying to redirect the phone to that phone number at all.


Start

Accept (--Triggering Contact--)

Select Resource (--Triggering Contact-- from CSQ)

Connected

Queued

Call Hold (--Triggering Contact--)

Delay 15 sec

Call Unhold (--Triggering Contact--)

Call Redirect (--Triggering Contact to "993991" --)

Successful

End

Busy

Invalid

Unsuccessful

Terminate (--Triggering Contact--)

End





  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
CHRIS CHARLEBOIS Tue, 12/09/2008 - 13:30
User Badges:
  • Silver, 250 points or more

First, I would make sure to dequeue the call vefore redirecting it, but I don't know that this would cause the problem.


Have you run this through the reactive debugger? Where does it fail?


My instinct tells me that it is a CSS problem with the JTAPI Route Ports, but there isn't enough information provided to be sure.

sturcott9891 Tue, 12/09/2008 - 18:36
User Badges:

I figured it out, I didn't understand completely what "connected" meant. I thought connected meant when the agent picks up the phone not the looking for agent process. What I was trying to do was make it so after 60 seconds or so regardless if someone is in ready or not it would go to voicemail. So essentially when I was testing it I wasn't doing it right because everyone was in ready status.


So I'm good now I appreciate your help though.

Actions

This Discussion