WLC DHCP issue with 3rd party client hardware

Unanswered Question
Dec 9th, 2008
User Badges:

Good time of day!

I've planning to manage my existing wireless network with WLC. I have a WLC 4402 with 4 (yet) registered 1310 AP's on it. AP's have statically assigned IP's and there's no problems with their registration on controller. The problem is with clients associated on this AP's, in concrete - with 3rd party client hardware (z-com, linksys, d-link, etc). This devices succefully associates with LAP, but wired clients attached to them are unable to obtain IP addresses from DHCP server, but, if i assign IP address to client manually (from dhcp pool), everything is fine. Also, there's no broblem with integrated (notebook) or PCI (USB) adapters, they get addresses from DHCP server without any problems. Is there a way to resolve this problem? Or maybe somebody ever faced such problem?


This is the only problem which doesn't allow me to deploy WLC in my network...

Any help would be appreciated, thank you.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dennischolmes Wed, 12/10/2008 - 12:03
User Badges:
  • Gold, 750 points or more

You probably have a dhcp by proxy issue. Try disabling dhcp by proxy. From the CLI:


config dhcp proxy disable


This command allows the dhcp request to be delivered directly to the dhcp server and not by the controller acting as a relay agent.

Alard_626 Thu, 12/11/2008 - 01:48
User Badges:

Thank you for reply, dennischolmes.


DHCP proxy is not the problem, clients doesnt get addresses with this option turned off, or even turned on.


Policy Manager State in Monitor-Clients is DHCP_REQD...

nathan.a.reeves Wed, 12/17/2008 - 19:27
User Badges:

Would be interested to know what code version you're running.


I saw a similar issue. The workaround was to setup the DHCP scope on the internal DHCP Server on the WLC but leave the scope deactivated. All worked then. This was a suggestion from a TAC Engineer I spoke with.


This may be resolved in the latest 5.2 code but I think there may still be some teething issues with this new release. Still taking a look at it.

Alard_626 Wed, 12/17/2008 - 22:15
User Badges:

Good time of day, Nathan.


My WLC is running

Product Version 5.2.157.0

I've set up internal DHCP scope as you said (without activating) and still no luck. Also i tried to activate it, and there's same issue: clients with integrated WiFi cards works like a charm, others - dont get addresses.

Maybe the reason is in my switch, which is non-Cisco, and i cannot change the native VLAN on it?

ericgarnel Thu, 12/18/2008 - 06:46
User Badges:
  • Gold, 750 points or more

if I understand you correctly, the wireless clients get dhcp, but devices that connect wired in the same subnet do not? My first thought is that you may not be allowing dhcp to reach the wired devices, either through not having ip helper-address setup or dhcp snooping on the switch is not trusted for the trunks or ports that lead to the dhcp server

Alard_626 Thu, 12/18/2008 - 07:12
User Badges:

Wireless clients that have integrated wireless cards (PCI or USB) get addresses, but, if wireless device is external (e.g Dlink-2100, or Zcom or Linksys or Zyxel), wired client attached to that device does not get address, while wireless device itself associates with no problem and get dhcp if configured so, and does not matter which type DHCP server i configure, internal or external - result is the same.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode