Script editor ICM 6 - "...don't own the script lock"

Unanswered Question

I'm running UCCE 6 (ICM 6.0) and I just installed the ICM Internet Script Editor on my computer.

When I try to save changes to a script I get the following error:

"You can not update the script because you don't own the script lock"

When I open the script locks, under file/script locks, it shows that I have it open.


We currently VNC to the HDS/AW in order to create/update scripts.


thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Voiceops SSC Wed, 03/24/2010 - 06:08
User Badges:


/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

I don’t know what version of ICM you're running but in my case (ver 6)  it was a security setting for my user account:

In Configuration Manager under User List, I went to my account and I unchecked the “Read only” check box and checked the “Webview and Script Editor only” box.

david.macias Wed, 03/24/2010 - 08:37
User Badges:
  • Blue, 1500 points or more

What happens when you go to File > Script Locks and remove the lock?  This is through Script Editor.


david

islam.irshaid Thu, 03/25/2010 - 02:48
User Badges:

Hi,


We have ver. 7.2.7


I unlocked the script many times but without any benefits , also I checked Lock Admin tool and everything is normal.


Thanks

Voiceops SSC Thu, 03/25/2010 - 04:42
User Badges:

Have you tried what I told you?


In the HDS/AW server, go to Configuration Manager open Security, click on User List, click on Retrieve, select the account you're using and look to see if the "Read Only" check box is checked. If is checked and grayed out, check the "Configuration" check box and uncheck the "Read Only" box then uncheck the "Configuration".

The "Webview" check box is probably checked for this user account.


This is what fixed it for me.

Voiceops SSC Tue, 05/04/2010 - 13:34
User Badges:

Did you figure this out? Now I'm running 7.5.1 and I'm running inot the same problem.


thanks

kimv Mon, 04/18/2011 - 18:50
User Badges:
  • Cisco Employee,

How are you logging into ISE?  Are you using the FQDN?


You all may be seeing the following defect.


Defect ID : CSCsl00802   
Defect Title : Cannot save script - because I do not own the script lock


Description: When saving a new script created with Internet Script Editor, the following error is displayed: "You cannot update the script because you do not own the script lock".


Note:  When I logged in I used the long name for domain "MIL.icm.com".  When using the short name "MIL" it works just fine.


Release-note:


Symptom: Cannot save script


Conditions: When saving a new script created with Internet Script Editor, the following error is displayed: "You cannot update the script because you do not own the script lock".


Workaround: Use the shorter version of the domain name (e.g. MIL) rather than using the longer domain version name(e.g. MIL.icm.com.


This is listed for Version(s) :7.5(1),8.0(1), however I would bet it is te same issue in previous releases.


Might want to give this a try...

Kim

Actions

This Discussion