CDP not providing the correct IP.

Unanswered Question
Dec 10th, 2008

Has any one ever seen the output of the show CDP neighbor detail command provide the wrong IP?

I am investigating an issue where the results of the command provide the wrong IP.

I am using a 3400 which connects back to a 3750. When issuing the command on the 3400, I see the wrong IP for the 3750.

If I issue the command on the 3750, the correct IP is shown for the 3400. There is only one management IP on the 3750; however, it is possible that another IP might have been on it in the past.

I have also attempted to clear the cdp table on the 3400.

Any help would be greatly appreciated.

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Edison Ortiz Wed, 12/10/2008 - 10:45

Expected behavior is to use the lowest Vlan IP address, can you post the output from typing show ip interface brief on the switch?

Even if the Vlan is in shutdown mode, it will use that IP.

__

Edison.

rdblaze13 Wed, 12/10/2008 - 11:05

Thanks so much for your help. Here is the output from a show ip int brief on the 3750:

3750#sh ip int bri

Interface IP-Address OK? Method Status Protocol

Vlan1 unassigned YES NVRAM administratively down down

Vlan99 10.62.147.186 YES manual up up

FastEthernet1/0/1 unassigned YES unset up up

FastEthernet1/0/2 unassigned YES unset up up

FastEthernet1/0/3 unassigned YES unset administratively down down

FastEthernet1/0/4 unassigned YES unset administratively down down

FastEthernet1/0/5 unassigned YES unset administratively down down

FastEthernet1/0/6 unassigned YES unset administratively down down

FastEthernet1/0/7 unassigned YES unset administratively down down

FastEthernet1/0/8 unassigned YES unset administratively down down

FastEthernet1/0/9 unassigned YES unset administratively down down

FastEthernet1/0/10 unassigned YES unset administratively down down

FastEthernet1/0/11 unassigned YES unset administratively down down

FastEthernet1/0/12 unassigned YES unset administratively down down

FastEthernet1/0/13 unassigned YES unset administratively down down

FastEthernet1/0/14 unassigned YES unset administratively down down

FastEthernet1/0/15 unassigned YES unset administratively down down

FastEthernet1/0/16 unassigned YES unset administratively down down

FastEthernet1/0/17 unassigned YES unset administratively down down

FastEthernet1/0/18 unassigned YES unset administratively down down

FastEthernet1/0/19 unassigned YES unset administratively down down

FastEthernet1/0/20 unassigned YES unset administratively down down

FastEthernet1/0/21 unassigned YES unset administratively down down

FastEthernet1/0/22 unassigned YES unset administratively down down

FastEthernet1/0/23 unassigned YES unset up up

FastEthernet1/0/24 unassigned YES unset up up

GigabitEthernet1/0/1 unassigned YES unset up up

GigabitEthernet1/0/2 unassigned YES unset up up

GigabitEthernet1/1/1 unassigned YES unset administratively down down

GigabitEthernet1/1/2 unassigned YES unset administratively down down

We use vlan 99 for management.

Here is the sh cdp neigh det on the interface that connects to fa 1/0/2 on the 3750. (Names edited for security purposes.)

Notice that the IP provided is not listed on the 3750. Weird...

3400#sh cdp neigh fa 0/24 det

-------------------------

Device ID: 3750

Entry address(es):

IP address: 10.62.144.38

Platform: cisco ME-C3750-24TE, Capabilities: Router Switch IGMP

Interface: FastEthernet0/24, Port ID (outgoing port): FastEthernet1/0/2

Holdtime : 146 sec

Version :

Cisco IOS Software, C3750ME Software (C3750ME-I5-M), Version 12.2(25)EY4, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Sat 13-May-06 06:42 by yenanh

advertisement version: 2

Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=00000000FFFFFFFF010221FF000000000000001955B7AD00FF0000

VTP Management Domain: 'Domain'

Native VLAN: 51

Duplex: full

Management address(es):

IP address: 10.62.144.38

Edison Ortiz Wed, 12/10/2008 - 11:15

Was that IP configured on this switch and removed but not rebooted?

If so, give it a reboot. You may be experiencing a cosmetic bug.

__

Edison.

Actions

This Discussion