2940 gigabit sfp port standby/disabled, need to get it working

Unanswered Question
Dec 10th, 2008

I get this on the fiber SFP port:

GigabitEthernet0/1 is standby mode, line protocol is down (disabled)

And I found some info that says I just need to reboot it with the SFP plugged in:

> As far as I remember, you should insert SFP and then reload switch.

> If you inserted SFP after boot - SFP port will be disabled, because

> onboard 100FX port will be selected as 'active uplink'

Is there any way to fix this without rebooting though? A reboot is not practical until the weekend, and I need to up before then. Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
mellestad Wed, 12/10/2008 - 15:23

Yea, made no difference. Shutdown does not even shut it down, the status of the interface remains what I have above. Standby, and disabled. When I shutdown a port, it usually says administratively down.

glen.grant Wed, 12/10/2008 - 15:23

Is that a dual purpose port ? If so you would have to select the media type .

mellestad Wed, 12/10/2008 - 16:14

No, it is a Cisco 2940. It has a 100base fx port, but it is not dual purpose. The FX is FA0/9 and the SFP is GI0/1. I found a post that was saying when the switch booted it selects the fx-100 port to be the primary if nothing is in the SFP port, and the SFO port is set to standby and the only way to reactivate it is a reboot.

I am hoping there is another way.

johnnylingo Tue, 06/26/2012 - 15:22

I've got a WS-C2940-8TF-S and from what I can tell the only way to activate Gi0/1 is to reboot the switch with an SFP plugged in. 

Actions

This Discussion