QoS - CoS voice/signalling

Answered Question
Dec 10th, 2008

typical config access port:

switchport mode access

switchport access vlan 5

switchport voice vlan 10

mls qos trust cos

mls qos trust device cisco-phone

mls qos vlan-based

config on vlan

int vlan 10

mls qos trust dscp

general

remap cos3 to DSCP x

remap cos 5 to DSCP 46

My question:

Q1) Will every cisco-phone 79xx automatically tag signalling traffic to cos 3 (skinny, H323,... dunno)and voice traffic to cos 5?

2) Or is it dependent on the cisco model

3)Or is class-map with ACL needed to classify signaling traffic and mark them in a policy map to cos 3? If yes, are there ACL templates for this

4) I've read this in callmanager guide for CCM 5.1

Cisco SIP phones get their DSCP information from the configuration file that gets downloaded to the device. The DSCP setting is for the device; whereas,

the SCCP phones can get the DSCP setting for a call.DSCP values get configured in the Enterprise Parameters Configuration window, and in the Cisco Unified CallManager Service Parameters Configuration window.

5)So this means for SIP phones: they'll use the DSCP value for voice and signalling as configured in the CCM? True/false

6) what means this part? whereas,

the SCCP phones can get the DSCP setting for a call.

Thank you very much!! I've no voice experience.

I have this problem too.
0 votes
Correct Answer by bigcappa1 about 5 years 4 months ago

The CIPC will send out the correct values also, where this falls down obviously is if the PC is connected to the back of an IP phone as the 79XX phone declassifies all PC traffic.

So assuming the PC with CIPC is not going into the back of a phone the vlaues the CIPC application send out will be the correct COS values

Paul

Correct Answer by bigcappa1 about 5 years 4 months ago

no you should not need to use ACLs the trust cos should be sufficient and set the mapping as stated.

If you have a sniffer such as wireshark you can use this to confirm what DSCP values are being sent between phones.

But in summary the switch should forward the tags without problem (I assume its a Cisco)

Paul

Correct Answer by bigcappa1 about 5 years 4 months ago

Davy,

1 and 2. Yes the phone tags the packets as required. COS 3 for signalling and COS5 for the voice stream. It is the same for all Cisco models as far as I know

3. You will ususally need to reclassify the packet where it hits a layer 3 or router junction. The layer 2 switches should forward the the tags and should also remap the cos-to-dscp values. (unless its the entry level 2950)

A show mls qos cos-to-dscp maps or similar should show you how they are mapped.

There should be no need for you to remap on the switch expect for the COS3 value. Old Cisco kit used to use DSCP value 26, the latest IPT kit uses DSCP value 24. I always remap this as the switch IOS is still programmed for the 26.

e.g

mls qos map cos-dscp 0 8 16 24 32 46 48 56

As for ACLs at the L3 junction the MLS qos should support this if not then you can use LLQ config to reclassify. Here is some config I have on a WAN router between 2 sites that also supports VC

class-map match-all VOICE-RTP

description VOIP Bearer Traffic

match access-group name VOICE

class-map match-all VOICE-CONTROL

description VOIP Control Traffic (SCCP, H225, H254, MGCP)

match access-group name CONTROL

class-map match-all VIDEO-CONF

description Video Conference Traffic

match access-group name VIDEO

!

!

policy-map VOIP-QOS

description Set DSCP for VOIP Control, ICCS and Bearer Traffic

class VOICE-RTP

priority percent 33

set ip dscp ef

class VOICE-CONTROL

bandwidth 16

set ip dscp cs3

class VIDEO-CONF

bandwidth 460

set ip dscp af41

class class-default

fair-queue

interface Serial0/1/0

bandwidth 1000000

ip address X.X.X.X 255.255.255.0

no cdp enable

service-policy output VOIP-QOS

ip access-list extended CONTROL

remark Match VoIP Control Traffic

remark SCCP

permit tcp any any range 2000 2002

remark H323 Fast Start

permit tcp any any eq 1720

remark H323 Slow Start

permit tcp any any range 11000 11999

remark H323 MGCP

permit udp any any eq 2427

ip access-list extended VIDEO

remark Match Video Streaming Traffic

permit ip any any dscp cs4

permit ip any any dscp af41

ip access-list extended VOICE

remark Match the UDP ports that VoIP uses for Bearer Traffic

permit udp any any range 16384 32767

5. From my understanding yes they will use the same value most likely COS5 they recive this instruction from the config file downloaded from the Callmanager

Hope this Helps

thanks

Paul

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (3 ratings)
Correct Answer
bigcappa1 Thu, 12/11/2008 - 01:54

Davy,

1 and 2. Yes the phone tags the packets as required. COS 3 for signalling and COS5 for the voice stream. It is the same for all Cisco models as far as I know

3. You will ususally need to reclassify the packet where it hits a layer 3 or router junction. The layer 2 switches should forward the the tags and should also remap the cos-to-dscp values. (unless its the entry level 2950)

A show mls qos cos-to-dscp maps or similar should show you how they are mapped.

There should be no need for you to remap on the switch expect for the COS3 value. Old Cisco kit used to use DSCP value 26, the latest IPT kit uses DSCP value 24. I always remap this as the switch IOS is still programmed for the 26.

e.g

mls qos map cos-dscp 0 8 16 24 32 46 48 56

As for ACLs at the L3 junction the MLS qos should support this if not then you can use LLQ config to reclassify. Here is some config I have on a WAN router between 2 sites that also supports VC

class-map match-all VOICE-RTP

description VOIP Bearer Traffic

match access-group name VOICE

class-map match-all VOICE-CONTROL

description VOIP Control Traffic (SCCP, H225, H254, MGCP)

match access-group name CONTROL

class-map match-all VIDEO-CONF

description Video Conference Traffic

match access-group name VIDEO

!

!

policy-map VOIP-QOS

description Set DSCP for VOIP Control, ICCS and Bearer Traffic

class VOICE-RTP

priority percent 33

set ip dscp ef

class VOICE-CONTROL

bandwidth 16

set ip dscp cs3

class VIDEO-CONF

bandwidth 460

set ip dscp af41

class class-default

fair-queue

interface Serial0/1/0

bandwidth 1000000

ip address X.X.X.X 255.255.255.0

no cdp enable

service-policy output VOIP-QOS

ip access-list extended CONTROL

remark Match VoIP Control Traffic

remark SCCP

permit tcp any any range 2000 2002

remark H323 Fast Start

permit tcp any any eq 1720

remark H323 Slow Start

permit tcp any any range 11000 11999

remark H323 MGCP

permit udp any any eq 2427

ip access-list extended VIDEO

remark Match Video Streaming Traffic

permit ip any any dscp cs4

permit ip any any dscp af41

ip access-list extended VOICE

remark Match the UDP ports that VoIP uses for Bearer Traffic

permit udp any any range 16384 32767

5. From my understanding yes they will use the same value most likely COS5 they recive this instruction from the config file downloaded from the Callmanager

Hope this Helps

thanks

Paul

davy.timmermans Thu, 12/11/2008 - 01:58

Ok,

Thus if I've a L3 switch I just have to adapt the cos to DSCP mapping.

With a L3 switch no ACL is needed unless if you'll use CIPC?

Correct Answer
bigcappa1 Thu, 12/11/2008 - 02:17

no you should not need to use ACLs the trust cos should be sufficient and set the mapping as stated.

If you have a sniffer such as wireshark you can use this to confirm what DSCP values are being sent between phones.

But in summary the switch should forward the tags without problem (I assume its a Cisco)

Paul

davy.timmermans Thu, 12/11/2008 - 02:35

indeed, cisco phones

thanks for the info

So only for CIPC, ACLs are needed because this data is coming from the pc

Correct Answer
bigcappa1 Thu, 12/11/2008 - 02:47

The CIPC will send out the correct values also, where this falls down obviously is if the PC is connected to the back of an IP phone as the 79XX phone declassifies all PC traffic.

So assuming the PC with CIPC is not going into the back of a phone the vlaues the CIPC application send out will be the correct COS values

Paul

Actions

Login or Register to take actions

This Discussion

Posted December 10, 2008 at 2:24 PM
Stats:
Replies:7 Avg. Rating:5
Views:614 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard