GSS interface not up

Answered Question
Dec 11th, 2008
User Badges:

I connect GSS into network via using UTP cable, both ends show down, even I change the configure to full duplex and 1000 speed, they don't go up. here is the configure of both ends:

GSS end:

GSS#sh run

interface ethernet 0

ip address 10.1.1.2 255.255.255.0

gss-communications

duplex full

speed 1000

interface ethernet 1

ip address 10.1.1.1 255.255.255.0

duplex full

speed 1000

--------------------

GSS#sh int eth0

Interface eth0

ip address 10.122.90.62 255.255.255.0

gss-communications

duplex full

speed 1000


Interface State

Link is down

Supported modes: 10-half, 10-full, 100-half, 100-full, 1000-half, 1000-full

Advertised modes:


Interface statistics

eth0 Link encap:Ethernet HWaddr 00:1E:68:0F:AD:C7

inet addr:10.x.x.1 Bcast:10.x.x.255 Mask:255.255.255.0

inet6 addr: fe80::21e:68ff:fe0f:adc7/64 Scope:Link

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Interrupt:177

switch end:

switch#sh run int g4/48

!

interface GigabitEthernet4/48

switchport

switchport access vlan 9

switchport mode access

no ip address

speed 1000

duplex full

spanning-tree portfast

end


SWITCH#sh int g4/48

GigabitEthernet4/48 is down, line protocol is down (notconnect)

Hardware is C6k 1000Mb 802.3, address is 001d.70b1.aa6f (bia 001d.70b1.aa6f)

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 0/255, rxload 0/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s

input flow-control is off, output flow-control is off

Clock mode is auto

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:16:26, output hang never

Last clearing of "show interface" counters never

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

41 packets input, 3649 bytes, 0 no buffer

Received 32 broadcasts (7 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

295 packets output, 25513 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out


I thought it was cable problem, i used my laptop connect to the switch with same cable, it wokred. can someone help me on this? thanks!

Correct Answer by sanjdutt about 8 years 4 months ago

GSS uses linux API (ethtool) to set speed/duplex value of interface. Ethool internally communicate to the NIC (network interface card) driver and alter the speed/duplex value. NIC driver comes with every NIC.

Different GSS hardware uses different NIC and different driver. All these NIC driver works fine to set speed/duplex value of interface with 10/FULL, 100/FULL. But works differently for 1000/FULL.

The different behaviors are listed below for different hardware

4480 : This device does not support 1000 Mbps with full duplex operation.

4490 : No change. Keep old value

4491 : Go to autonegotiation mode

4492 : Go to 10 Mbit, full duplex


Only 4491 hardware provides the support for 1000/FULL


For more info pls see the following bug

CSCsf17052 : GSS 4492 Interface will not link when speed/duplex are hard set.


Correct Answer by rajesh.perumalla about 8 years 4 months ago

Hi,


Refer this Bug


CSCsf17052-When a GSS is connected to a CAT6500 and both the devices are hard set to 1000/full, the Ethernet link does not come up. If you set the GSS to auto speed/duplex, the link does come up and remains up even after you change the interface configuration back to 1000/full. This is not ideal behavior because once the cable is unplugged/plugged, the link will again go down and remain down as both devices are set to 1000/full.


Workaround: Set both devices to autonegotiate


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
rajesh.perumalla Thu, 12/11/2008 - 16:52
User Badges:

Hi,


Refer this Bug


CSCsf17052-When a GSS is connected to a CAT6500 and both the devices are hard set to 1000/full, the Ethernet link does not come up. If you set the GSS to auto speed/duplex, the link does come up and remains up even after you change the interface configuration back to 1000/full. This is not ideal behavior because once the cable is unplugged/plugged, the link will again go down and remain down as both devices are set to 1000/full.


Workaround: Set both devices to autonegotiate


shibindong Thu, 12/11/2008 - 18:41
User Badges:

thanks. I will change the configure and let you know the result later.

Correct Answer
sanjdutt Fri, 12/12/2008 - 02:07
User Badges:

GSS uses linux API (ethtool) to set speed/duplex value of interface. Ethool internally communicate to the NIC (network interface card) driver and alter the speed/duplex value. NIC driver comes with every NIC.

Different GSS hardware uses different NIC and different driver. All these NIC driver works fine to set speed/duplex value of interface with 10/FULL, 100/FULL. But works differently for 1000/FULL.

The different behaviors are listed below for different hardware

4480 : This device does not support 1000 Mbps with full duplex operation.

4490 : No change. Keep old value

4491 : Go to autonegotiation mode

4492 : Go to 10 Mbit, full duplex


Only 4491 hardware provides the support for 1000/FULL


For more info pls see the following bug

CSCsf17052 : GSS 4492 Interface will not link when speed/duplex are hard set.


Actions

This Discussion