ASDM Failed to Load

Unanswered Question
Dec 11th, 2008

I have recently upgraded a PIX 525 to 8.04 and have loaded ASDM 6.13. When I https to the PIX it gives me the ASDM splash screen and allows the install/upgrade of ASDM on my PC (WinXP) to occur.

I can run it from either my PC or from the web page and get the same result. The launcher prompts me for authentication, loads the software (progress bar moves along the top), completes according to the text in the window, then pops up a dialog box that says the following:

----------

Error

ASDM cannot be loaded. Click OK to exit ASDM.

Unconnected sockets not implemented

------

| OK |

------

-----------------

Java seems fine. WinXP firewall is off. ASDM has been uninstalled and reinstalled.

Anyone have any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
Loading.
JORGE RODRIGUEZ Thu, 12/11/2008 - 14:44

You did not specify what java version you are running but there is some compatibility issues with java JRE latest version and asdm.

I did resolved the exact same error message you are geting when loading asdm and sockets from an XP machine that was running the latest java JRE version update 10

Uninstall whatever version you have, and install java version 6 update 7.

I speak for code 8.04 and asdm 6.1.3

Cisco Adaptive Security Appliance Software Version 8.0(4), Device Manager Version 6.1(3).

go to this link Where it saids JDK/JRE Pick version 6 update 7

http://java.sun.com/products/archive/

or go directly here

https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_Developer-Site/en_US/-/USD/ViewProductDetail-Start?ProductRef=jre-6u7-oth-JPR@CDS-CDS_Developer

HTH

Jorge

PLS rate any helpful post if it helps

jim-bell Wed, 12/17/2008 - 15:21

Thanks Jorge downgrade to Java v6 update 7 worked a treat.

Regards

Jim.

nlariguet Thu, 12/11/2008 - 18:17

I got the same error today with ASDM 6.1.3 after the Java updater updated the JRE today, no problems before

the conflict is obviously with the latest JRE update ... mine is now 6 update 11 (build 1.6.0_11-b03) under Windows 2003 Server R2 EE fully updated

don.click1 Mon, 12/15/2008 - 16:47

I downgraded my java based on jorgemcse's suggestion, and it is working perfectly now. Thank you for the tip!

(trying to troubleshoot bandwidth issues this evening!)

mniklasson Tue, 12/30/2008 - 02:25

I got the same problem when I upgraded to JRE 6 update 10. I recently upgraded to update 11, but the problem persists.

JORGE RODRIGUEZ Tue, 12/30/2008 - 05:12

What version of asdm code are you running, you either have to downgrade JRE to update 7, or upgrade your ASDM version. See bellow info for details.

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsv12681

CSCsv12681 Bug Details

Symptom:

While loading ASDM, a dialog is displayed that says:

"ASDM cannot be loaded. Click OK to exit ASDM.

Unconnected sockets not implemented"

This occurs when using Java 6 Update 10 or later.

Conditions:

ASDM version 5.0 or later running on ASA, PIX or FWSM and using Java 6

Update 10 or later.

Workaround:

Use Java 6 Update 7.

1st Found-In

5.0(8)

5.1(2)

5.2(4)

6.1(5)

5.2(4)F

6.1(1)F

Fixed-In

6.2(0.70)

6.2(0.71)

6.1(1.55)F

5.2(4.51)

6.1(5.51)

Actions

This Discussion