Extra digits

Unanswered Question
Dec 11th, 2008

Hi All,

We are using Cisco 2800 series router as PSTN Gateway on which E1-PRI from different ervice providers is terminating.

Problem which we are facing is DID is not working for one service provider while working for others.

Service Provider says that CLI is incomplete.

Service Provider wants that some extra digits should be added like complete number prefixed by Area Code for him to make DID work.As of now, when call is made, Pilot number is displayed at receiving end.

We are using dial peer pots & voip.Is it possible to add some extra digits when any call is made from IP phone to PSTN world?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jaime Valencia Thu, 12/11/2008 - 20:11

yes. use the prefix command under dial peer or translation rules



if this helps, please rate

amansoi_5 Fri, 12/12/2008 - 05:41

Hi Sir,

I tried adding prefix command under dial peer pots but my outgoing stops working.



Jaime Valencia Fri, 12/12/2008 - 06:02

without a good description of what digits or routing you need there is little we can tell you to do. if it does not work best guess it's misconfiguration



if this helps, please rate

amansoi_5 Fri, 12/12/2008 - 10:38

Hi sir,

I am attaching the configuration of Voice Gateway for your reference.

Under dial peer voice 19 pots ,PRI from Reliance Service provider is connected which has got the preference as 1.

DID facility is enabled on this particular PRI. Now whenever any outgoing call is made, always the Pilot number is displayed at receiving end. The customer wants that DID number should be displayed. Service provider says that u need to add 124 as area code along 30688888 instead of 30688888 so as to complete CLI.

Now when I prefix 124 , we are unable to make ourgoing calls.



CHRIS CHARLEBOIS Fri, 12/12/2008 - 11:50

Let me make sure I understand the problem correctly... Calls out of the E1 are completing now, but the Caller ID information is not coming through correctly. Is that right?

That would make sense. The prefix command would modify the called number, not the Caller ID. The easiest place to do this is on the CUCM. Change the Caller ID DN on the H323 Gateway configuration to 124XXXXXXXXX.

Of course, that may not be an option, because not all calls coming from the CUCM to this Gateway will be using this interface. I believe there is a way to translate the outgoing Caller ID number, but I don't know it off the top of my head.

amansoi_5 Mon, 12/15/2008 - 05:18

Hi Charlie,

I tried the option suggetsed by you but no change was observed.

Under the route pattern, Calling Party Transformation--Prefix Digits (Outgoing Calls), I added the reuiqred number & DID is working fine.




This Discussion