Unanswered Question
Dec 14th, 2008

I have a 2621XM router and I need to config the it for PPPOE for my AT&T service. Will the config below work for me? I only have Fastethernet interfaces on this router. Also where do I type my username and password for the PPPOE login to the internet service.


hostname pooh

ip host rund


ip subnet-zero

no ip domain-lookup


vpdn enable

no vpdn logging


vpdn-group 1


protocol pppoe





interface Ethernet0/0

ip address

ip nat inside

no ip mroute-cache





interface Ethernet0/1

no ip address

pppoe enable

pppoe-client dial-pool-number 1


interface Dialer1

ip address negotiated

ip nat outside

ip mtu 1492

encapsulation ppp

no ip mroute-cache

dialer pool 1

dialer-group 1

ppp authentication pap

ppp pap sent-username cisco password cisco1


ip classless

no ip http server


dialer-list 1 protocol ip permit

ip nat inside source list 1 interface Dialer1 overload

ip route dialer1

access-list 1 permit


line con 0

exec-timeout 0 0

transport input none

line vty 0 4


password ww


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Laurent Aubert Sun, 12/14/2008 - 12:33


If you don't know the authentication protocol your ISP is expecting, configured both (PAP and CHAP)

Also you usually don't authenticate the ISP device so the config should looks like this:

interface Dialer 1

ppp authenticate pap chap callin

ppp pap sent-username cisco password cisco1

ppp chap hostname cisco

ppp chap password cisco1

Replace cisco/cisco1 by your login credentials received from your ISP

Troubleshooting links:


(just replace the ATM interface by your Fast interface)


Hope this helps




This Discussion