cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
249
Views
0
Helpful
2
Replies

PPPOE CLIENT CONFIG Question

Charlie Mayes
Level 1
Level 1

I have a 2621XM router and I need to config the it for PPPOE for my AT&T service. Will the config below work for me? I only have Fastethernet interfaces on this router. Also where do I type my username and password for the PPPOE login to the internet service.

!

hostname pooh

ip host rund 172.17.247.195

!

ip subnet-zero

no ip domain-lookup

!

vpdn enable

no vpdn logging

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

!

interface Ethernet0/0

ip address 10.200.56.22 255.255.255.0

ip nat inside

no ip mroute-cache

!

!

!

!

interface Ethernet0/1

no ip address

pppoe enable

pppoe-client dial-pool-number 1

!

interface Dialer1

ip address negotiated

ip nat outside

ip mtu 1492

encapsulation ppp

no ip mroute-cache

dialer pool 1

dialer-group 1

ppp authentication pap

ppp pap sent-username cisco password cisco1

!

ip classless

no ip http server

!

dialer-list 1 protocol ip permit

ip nat inside source list 1 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 dialer1

access-list 1 permit 10.200.56.0 0.0.0.255

!

line con 0

exec-timeout 0 0

transport input none

line vty 0 4

login

password ww

!

2 Replies 2

Laurent Aubert
Cisco Employee
Cisco Employee

Hi,

If you don't know the authentication protocol your ISP is expecting, configured both (PAP and CHAP)

Also you usually don't authenticate the ISP device so the config should looks like this:

interface Dialer 1

ppp authenticate pap chap callin

ppp pap sent-username cisco password cisco1

ppp chap hostname cisco

ppp chap password cisco1

Replace cisco/cisco1 by your login credentials received from your ISP

Troubleshooting links:

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a7c2.shtml#l2

(just replace the ATM interface by your Fast interface)

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a6c3.shtml

Hope this helps

Thanks

Laurent.

Thanks so much. I will try it and see how it work out.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card