No voice path when PABX crosses router to Telco

Unanswered Question
Dec 14th, 2008


Can I see if anyone has any clue why there is no voice path when i cross router for external calls.

We are using MGCP controller routers on CM4.2(3).

This is our setup now, we have a Nortel PABX which has 2 QSIG connections, each to Router 1 and Router 2. We also have 4 ISDN30 to a Telco provider, two connecting to each router.

PABX QSIG1 -- Router 1 -- TelcoA1

-- TelcoA2

PABX QSIG2 -- Router 2 -- TelcoA3

-- TelcoA4

From PABX phone, if we dial an outgoing call to the Telco and if it routes to Router 1 and to TelcoA1 or TelcoA2, the call would go through, voice path is correct.

If it routes to Router 1 and CallManager routes it out to TelcoA3 or TelcoA4, the call would be establish however, there is no voice path and users cannot hear anything

This is also the same issue vice versa if we route to router 2 and to TelcoA1, TelcoA2.

The two routers is in the same network segment, no firewall between.

Thanks in advance,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Nicholas Matthews Mon, 12/15/2008 - 05:52

Hi Eugene,

If these two routers have multiple IP addresses, you will want to use the 'mgcp bind media' command to make sure they're communicating using the IP addresses you expect. There are some issues with this command in early 12.4 mainline, so use 'show mgcp' to confirm that the bind command has taken.

Generally one-way audio issues are caused by:

-one-way routing


-policy routing



-DSP problems

In this case it sounds like something other than a DSP problem because you have successful calls through the gateways.

I would get a 'show call active voice brief' and look at the tx/rx packets for the call legs pointing towards the other MGCP gateway. Make sure that you see the IP addresses that you expect, and that you can ping between them.


This Discussion