Speed and duplex settings

Unanswered Question
Dec 15th, 2008
User Badges:

Hi Guys,


had a small Q; I have a switch connecting to a router. The interface settings on the switch is auto and auto. Whereas on the router it's configured to be 100 full. Now I get errors on the interface (both sides). The very moment I configure the port on the switch to 100 full all starts working fine. The reason is that while using auto the switchport negotiates itself to half D rather than full D. Why does this happen is there any explaination to it. (both devices are Cisco)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
scottmac Mon, 12/15/2008 - 07:46
User Badges:
  • Green, 3000 points or more

There are several possibilities.


The cable connecting the two could be bad (hand made (wrong/poorly), bad termination, stretched, bent, kinked, crushed ...)


Depending on the switch and / or router's generation and IOS load, having Auto on one side and hard-set parameters on teh other will generate errors like you describe.


Auto/Auto on both sides, with negotiation down to half duplex and / or 10meg / Half Duplex tends to indicate a problem with the path between the two.


Good Luck

Scott


glen.grant Mon, 12/15/2008 - 09:07
User Badges:
  • Purple, 4500 points or more

The port can always detect the speed but it cannot auto sense the duplex unless the other end is also auto so if it cannot sense the duplex it uses the default of half duplex which is the correct behavior . As a best practice always make both ends the same , if one end is hardcoded the other end "must" be hardcoded. If it is set as auto then the other end must be auto otherwise you will always get a speed/duplex mismatch and the associated errors .

fjcardenas-1 Tue, 12/16/2008 - 10:17
User Badges:

When you manually configure duplex and speed in one end, autonegotiation is disabled in that interface. Because of that, the other end uses default duplex settings.

1) If the speed is not known it uses 10 Mbps Half.

2) If the speed is known to be 10 or 100 Mbps it uses Half.

3) If the speed is known to be 1000 Mbps it uses full duplex.

In your case autonegotiation is diabled in one end, so the other end defaults to use Half Duplex and that issues in a duplex mismatch causing errors and collitions. When you force the other end to also use Full Duplex your problem is solved as you mention.


Hope this helps.


letsgomets Tue, 12/23/2008 - 11:20
User Badges:

autonegotiate on duplex will default to half when it can not autonegotiate.

You are setting it to full on one side and auto on the other. They can not negotiate this way.


Set them both the same way and you should be good.

Actions

This Discussion