RME 4.0.6 advanced baseline template question

Answered Question
Dec 15th, 2008
User Badges:

I've tried just about everything I could think of (yes, I've read the documentation) to do the following:


policy-map WAN-OUT

class class-default

fair-queue


The first statement, "policy-map WAN-OUT" is already on all the routers, but the next two may not be. I did a basic template to look for "class class-default" and have identified the routers that do not have the 2nd two statements but I have tried to create an advanced template to do a 'deploy and simple can't get it to: 1)Do a compliacny check and come up with the same results as the basic template (so that I know the advanced version is working correctly) and then, later, do a deploy.


The documentation is VERY sketchy and I'm spending too much time doing trial and error.


Any suggestions with a walk-through so I can actually understand how a double nested command will work?


I started off with a global command set(1) to do the first statement, but can't figure out if the "+ class class-default" should go into the list of commands at that point (something has to or you'll get an error when you try to save it).


Pretty confusing.

Correct Answer by Joe Clarke about 8 years 4 months ago

Sounds like there is still something wrong with your template. Here is one which should work.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Mon, 12/15/2008 - 11:19
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I think what you want is something like:


Submode: policy-map WAN-OUT

Commands:


+ class class-default

+ fair-queue

philip.r.hayes Mon, 12/15/2008 - 11:27
User Badges:

Ooooh. That's too easy. ha!


The thing is that the "fair-queue" is a subcommand to "class class-default" so I was under the assumption that I needed to first do a global command, "policy-map WAN-OUT", then do another subcommand under that for "class class-default" and then the final command under the "class..." command. On the router itself, the "class..." is indented and under that the "fair..." is indented.


Flip

Joe Clarke Mon, 12/15/2008 - 11:40
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You'll need two commandlets in the same template, one the parent of the other:


Commandlet 1:


Submode: policy-map WAN-OUT

Commands:


+ class class-default


Commandlet 2:


Parent: Commandlet 1

Submode: class class-default

Commands:


+ fair-queue

philip.r.hayes Mon, 12/15/2008 - 11:56
User Badges:

I think that's what I have. But let's check.


I have a global "commandset":

Name: PolicyWFQ

Submode: policy-map WAN-OUT

Mark as Prerequisite: "checked"

CLI Commands: + class class-default


Now, should I create a command"set" that is also global or nest it under this first one?


If I don't nest it, would I make it the following global commandset?:

Name: ClassDefault

Subcommand: class class-default (??)

Prerequisite: PolicyWFQ

Mark as Prerequisite: (leave unchecked)

CLI Commands: + fair-queue


Prior to this conversation, I made the 2nd commandset nested under PolicyWFQ


Flip



Joe Clarke Mon, 12/15/2008 - 11:58
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You don't need to make PolicyWFQ a prerequisite, but you can. The ClassDefault command set should be a child of PolicyWFQ. Everything else looks correct.

philip.r.hayes Mon, 12/15/2008 - 13:09
User Badges:

The report that came back seemed OK but the non compliant devices showed:


+ policy-map WAN-OUT

+ fair-queue


I don't see the subcommand of the policy-map of "+ class class-default".


So, if I run a deploy, I assume it would put "fair-queue" directly under the "policy-map WAN-OUT; or at least attempt to.


In fact, I already tried this scenario. Shouldn't I see all three statements on the report?


Also, I did notice that the "+ fair queue" was indented on the report.

Correct Answer
Joe Clarke Mon, 12/15/2008 - 15:33
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Sounds like there is still something wrong with your template. Here is one which should work.



Actions

This Discussion