ISSUES: c2950G-24-EI

Unanswered Question
Dec 15th, 2008

Just purchase two WS-C2950G-24-EI switches. Both are labeled to be manufactured in 2004.

Problem I have is one switches blink the SYST LED amber, while STAT is solid green. I'm unable to console into it..

Second switch I seem to be able to console into. What worries me is it will continuously crash. Info here, but seems to be configurable at this point... I've completed a #write erase, reload; since it still had the previous config loaded, but hangs after reload and unable to console in until I power off the unit.... output.

http://pastebin.com/d2e928ceb

s: com4

b: 9600

sb: 1

p: n

fc: n

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 1 (1 ratings)
Loading.
glen.grant Mon, 12/15/2008 - 13:27

Think I would try a new version of code on both that is pretty old . Possible the code is corrupted.

mrbclark Fri, 12/19/2008 - 13:57

Would you mind sifting through this mess of replies and help determine if this is hardware related?

viyuan700 Mon, 12/15/2008 - 13:42

First one where you have amber light on SYST LED, means one or more power on self test is failes system malfunction.

Tell the person from whom you have bought this as you cannot do anything. he cannot sell you things that is not working.

But your other switch looks fine. You are at swith USer mode prompt just go to other mode and define Ip etc.

You could have set those things if u have said yes at this prompt

"Would you like to enter the initial configuration dialog? [yes/no]: n "

I donot know why r u saying no everytime and then realoading or erase.

viyuan700 Mon, 12/15/2008 - 18:07

For the one it show amber light i think there isno soultion. have you taken from ebay as they give you 7-10 days to check whether it working perfectly. I think you shd talk to them.

You reset the switch 10-15 times just to remove the old vlan info. Vlan info is not in nvram. Even if u erase it 100 times it will show up again.

To remove vlan info either go to vlan database mode and say no vlan(tell the number you want to erase) or erase vlan file in flash.

If you say sh flash: u will see a vlan.dat file i think. If you delete that file all ur old info will go.

Before doing all this i will suggest you to setup a TFTP server and copy image from switch to your PC.

mrbclark Thu, 12/18/2008 - 15:25

Ok, so I've backed up the IOS to my PC. Attempted to delete the IOS from flash then the system crashed ><

http://pastebin.com/m1282adf0

Now, whats the proper format to upload the image? Please give an example... I'm not good at deciphering this "usage: copy [-b ] "

mrbclark Thu, 12/18/2008 - 16:40

Would work if Vista had hyperterminal... and there is no xmodem for putty.

viyuan700 Thu, 12/18/2008 - 17:36

one of my freind got hyperterminal for vista too google it i think u will get it.

U could have tried to remove other things and see if u can have 2 image on flash this way u could have tried things faster.Instead of deleting the old one.

mrbclark Thu, 12/18/2008 - 18:10

HyperTerminal is no longer available, as a Free application. If you want to use it you'll need to purchase a license, which I'm not about to do just for this.

The comment of "what should have been done" , frankly the flash would not handle two images, regardless, I asked what items I can remove in the previous post, the old ios was a must as two would not have fit........

Anyhow, I'm not here to argue... if you're going to reply please read my posts and post Relevant information!

This is the response I receive after attempting to xmodem via the XP version of HyperTerminal:

----------------------------------------------

switch: copy xmodem: flash:c2950-i6q4l2-mz.121-22.EA1.bin

Begin the Xmodem or Xmodem-1K transfer now...

CCCCCCCCCCBB0BB0xmodem:: I/O error

switch: boot flash

Loading "flash"...flash: permission denied

Error loading "flash"

Interrupt within 5 seconds to abort boot process.

Boot process failed...

---------------------------------------------

Switched back to putty and this is what I receive:

---------------------------------------------

switch: IP_ADDRESS=172.20.16.100

switch: IP_SUBNET_MASK=255.255.255.128

switch: DEFAULT_GATEWAY=172.20.16.1

switch: TFTP_SERVER=172.20.16.101

switch: TFTP_FILE=c2950-i6q4l2-mz.121-22.EA1.bin

switch: tftpdnld

Unknown cmd: tftpdnld

switch: tftpdnld

Unknown cmd: tftpdnld

switch:

switch: tftpdnld

Unknown cmd: tftpdnld

switch: tftpdnld:

Unknown cmd:

switch: tftpdnld

Unknown cmd: tftpdnld

viyuan700 Thu, 12/18/2008 - 18:27

tftpdnld i have seen for router i think it's not there for switch so will not work.

In your flash i think it is all the old files and even if you lost you will not mind. You can first format the flash and then write though xmodem with ur XP.

At 9600 it will take time to transfer to set the speed to 115200 by command (it depends on terminal some dont take so if it dont come reset again to 9600)

set BAUD 115200

you have to restart ur hyperterminal and select speed 115200 for full process read the link sent you ealier.

Dont forget to set again 9600 if it takes 115200.

mrbclark Thu, 12/18/2008 - 18:53

Which I've done and stated in my previous post.....

switch: copy xmodem: flash:c2950-i6q4l2-mz.121-22.EA1.bin

Begin the Xmodem or Xmodem-1K transfer now...

CCCCCCCCCCBB0BB0xmodem:: I/O error

update:

switch: set BAUD 115200

switch: BB0BB0

Unknown cmd: BB0BB0

switch: copy xmodem: flash:

switch: copy xmodem: flash:c2950-i6q4l2-mz.121-22.EA1.bin

Begin the Xmodem or Xmodem-1K transfer now...

CCCCCCCCCCBB0BB0xmodem:: I/O error

switch: unset BAUD

switch: BB0BB0

Unknown cmd: BB0BB0

switch: set BAUD 115200

switch: BB0BB0BB0BB0BB0

Unknown cmd: BB0BB0BB0BB0BB0

switch: unset BAUD

switch: set BAUD 57600

switch: copy xmodem: flash:c2950-i6q4l2-mz.121-22.EA1.bin

Unknown cmd: copy

switch: BB0BB0

Unknown cmd: BB0BB0

switch: unset BAUD

switch:

All of which reproduce the same I/O Error (No response from remote system).

viyuan700 Thu, 12/18/2008 - 19:18

in drop down menu of send file after selecting the file are you selecting x-modem in protocol drop down menu.

In protocol it has to be xmodem.

if it has problem with different speed just go with 9600 it will take time but better.

vishwancc Mon, 12/15/2008 - 22:35

Hi,

What is will suggest go to the Rommon,and upgrade the IOS .It seems there are lot of bugs for this IOS.

Chao

Vishwa

mrbclark Mon, 12/15/2008 - 22:56

We're can I obtain the latest working release for this switch? Again, this is only a personal lab and no production environment.

mrbclark Thu, 12/18/2008 - 23:57

With all do respect, I have done all of the aforementioned, and previously stated it....

viyuan700 Fri, 12/19/2008 - 08:40

Under support tab there is option download software you can download new image for your switch. If that can help.

I have tried the same proces 3-4 times without having any problem and i dont know what is problem with yours.

Few things which i noticed you are just typing something. Like you set baud rate to 115200 then you tried to unset it. There is no such unset command.When you set baud with new speed it overwrites the earlier one.

Read the document carefully and follow the process as it has told in that document.

Just go through all the message and see did i told you to delete the image i told you to backup NOT delete. That too after watching you using write erase frequnetly in case you erase image also.

mrbclark Fri, 12/19/2008 - 13:47

unset BAUD is a valid command. If the BAUD rate is not reset, you will not be able to console back in, until the switch has been reset.

http://www.cisco.com/en/US/products/hw/switches/ps628/products_tech_note09186a0080169696.shtml

FYI: I never stated any such thing... I backed up the image and deleted it from flash because there was no more room, if this is a working switch TFTPdnld or XMODEM would work and deleting is not an issue. So don't be lecturing me about what you think I assumed of you... so stop!

My issue is uploading the image to the switch it's quite obvious there. I've noted every step I made and posted it, but you constantly overlook that work...

The connection is breaking somewhere, previously noted post, the switch isn't responding to either XMODEM or tftp, which is why changing the baud rate was necessary troubleshooting.

glen.grant Sun, 12/21/2008 - 05:21

The only thing I can add is if you can't see anything via the console try changing the speeds on your terminal emulator from 9.6 to the other speeds like 19.6,36.4 all the way up to 115200 and see if you can get any output out of the thing . I also would try to use something other than hyperterm like Tera Term for your terminal emulator . If you try the software recovery again after that and it still doesn't work then the hardware is probably toast. You could try and get cisco to replace it as they have a lifetime warranty but I don't know the stipulations of that warranty whether its for the original purchaser etc...

Actions

This Discussion