ACE context syslog

Answered Question
Dec 16th, 2008
User Badges:

Hi!


Does someone know how to configure the syslog under a context?

The syslog should be send via public interface. No additional management interface should be configured.


Any ideas?

Correct Answer by dario.didio about 8 years 5 months ago

Can you configure for example:


logging trap 6


This specifies that messages between 0-6 are send to the syslog server specified by the "logging host" command.


I don't know which severity is the default value.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
dario.didio Tue, 12/16/2008 - 04:40
User Badges:
  • Silver, 250 points or more

Hi,


you can configure syslog under each context separatly.


Please refer to following document.

http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA1_7_/configuration/system/message/guide/config.html#wp1059844


Normally, the ACE will use its public interface due to its routing table (default route is pointing to public interface)


Hope this helps!

celiocarreto Tue, 12/16/2008 - 05:13
User Badges:

I configured it as described in the manual.

In the Admin context it works. In a sub-context not. No Packets are sent by the ACE appliance.


Any other ideas or working configurations?

dario.didio Tue, 12/16/2008 - 05:17
User Badges:
  • Silver, 250 points or more

I'm using it in different contexts and it works fine.


can you upload your config?

celiocarreto Tue, 12/16/2008 - 05:58
User Badges:

The configuration is basicly:


logging enable

logging fastpath

logging console 1

logging timestamp

logging buffered 5

logging persistent 6

logging monitor 5

logging facility 21

logging queue 1024

logging device-id context-name

logging host 195.122.17.210 udp/514

logging rate-limit 42 60 level 5

logging rate-limit 42 60 level 6

logging rate-limit 42 60 level 7


access-list V101-IN line 1 extended permit icmp 195.122.1.0 255.255.255.0 195.

122.1.0 255.255.255.0

access-list V101-IN line 2 extended permit icmp any host 195.122.1.6

access-list V101-IN line 3 extended permit icmp any host 195.122.1.5

access-list V101-IN line 10 extended permit icmp any host 195.122.1.17

access-list V101-IN line 20 extended permit icmp any host 195.122.1.18

access-list V101-IN line 30 extended permit icmp any host 195.122.1.19

access-list V101-IN line 40 extended permit tcp any host 195.122.1.17 eq www

access-list V101-IN line 50 extended permit tcp any host 195.122.1.18 eq www

access-list V101-IN line 60 extended permit tcp any host 195.122.1.19 eq www

access-list V101-IN line 68 extended permit tcp any host 195.122.1.17 eq https


interface vlan 3

description WL-Server-Frontend

ip address 10.125.145.253 255.255.255.0

alias 10.125.145.254 255.255.255.0

peer ip address 10.125.145.252 255.255.255.0

service-policy input ICMP-ALLOW

no shutdown


interface vlan 101

description outside

ip address 195.122.1.5 255.255.255.0

alias 195.122.1.6 255.255.255.0

peer ip address 195.122.1.4 255.255.255.0

access-group input V101-IN

service-policy input L4-V101-LB

no shutdown



ip route 0.0.0.0 0.0.0.0 195.122.1.1



Correct Answer
dario.didio Tue, 12/16/2008 - 06:09
User Badges:
  • Silver, 250 points or more

Can you configure for example:


logging trap 6


This specifies that messages between 0-6 are send to the syslog server specified by the "logging host" command.


I don't know which severity is the default value.


dario.didio Tue, 12/16/2008 - 07:38
User Badges:
  • Silver, 250 points or more

your welcome, thanks for the rating

Actions

This Discussion