LMS 3.1 Campus Manager 5.1.0 - ANIServer process trouble

Answered Question

No matter what i do i just cant seem to get the ANIServer process to run. I have even restored the campus manager DB.

Please please help. thank in advance

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 7 years 11 months ago

The ANIServer.properties is completely corrupt. Copy NMSROOT/campus/etc/cwsi/ANIServer.properties.orig to ANIServer.properties. Then modify the file, and change the DEVICESROOT line to read:

DEVICESROOT=NMSROOT\\campus\\lib\\classpath

Where NMSROOT is the path into which LMS was installed (e.g. C:\\PROGRA~1\\CSCOpx). Also, change the AniName line to:

AniName=ANIServer6.0-boe-ciscoworks2

After that, ANIServer should start.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Tue, 12/16/2008 - 08:19

It appears you have a few problems. First, check the permissions on d:\PROGRA~1\CSCOpx\campus\etc\cwsi\ANIServer.properties. Make sure the casusers group has full control to this file, and all parent directories. Second, the ANI database appears to be down. Please post the output of the pdshow command.

Thanks

The casuser has full rights to the file and all of the D: in fact

D:\Program Files\CSCOpx\campus>pdshow ANIServer

Process= ANIServer

State = Failed to run

Pid = 0

RC = -1

Signo = 1073741823

Start = N/A

Stop = 12/16/2008 4:25:57 PM

Core = Not applicable

Info = Application failed or was registered incorrectly.

Joe Clarke Tue, 12/16/2008 - 08:33

I wanted to see the entire pdshow output. Additionally, please post NMSROOT/campus/etc/cwsi/ANIServer.properties.

Correct Answer
Joe Clarke Tue, 12/16/2008 - 08:46

The ANIServer.properties is completely corrupt. Copy NMSROOT/campus/etc/cwsi/ANIServer.properties.orig to ANIServer.properties. Then modify the file, and change the DEVICESROOT line to read:

DEVICESROOT=NMSROOT\\campus\\lib\\classpath

Where NMSROOT is the path into which LMS was installed (e.g. C:\\PROGRA~1\\CSCOpx). Also, change the AniName line to:

AniName=ANIServer6.0-boe-ciscoworks2

After that, ANIServer should start.

Actions

This Discussion