Qos in egress switch port

Unanswered Question
Dec 16th, 2008


when mls qos is enabled on 3560 catalyst switch, if the speed of the interface is 100Mb,ther are some drop in transmit, see below. Some body can help me ?

sho platform port-asic stats drop gig 0/1

Interface Gi0/1 TxQueue Drop Statistics

Queue 0

Weight 0 Frames 7551

Weight 1 Frames 0

Weight 2 Frames 0

Queue 1

Weight 0 Frames 1980811

Weight 1 Frames 50

Weight 2 Frames 0

Queue 2

Weight 0 Frames 0

Weight 1 Frames 0

Weight 2 Frames 0

Queue 3

Weight 0 Frames 0

Weight 1 Frames 0

Weight 2 Frames 0

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
letsgomets Tue, 12/23/2008 - 11:17

Are you wondering why you are getting drops?

If so is the link utilization high?

b-aumand Tue, 01/20/2009 - 06:31


For example when a giga interface is negaciate in auto at 100Mb/s and the use is near 100 mb/s I have lot of drop it also the case when the interface is negociate at 10Mb/s

Joseph W. Doherty Tue, 01/20/2009 - 07:07

On almost any interface where the traffic rate offered exceeds the inteface's tranmission rate, excess traffic is usually queued but the queue will often "overflow" and drop packets. For some traffic, such as TCP, dropped packets inform the sender to slow down. This is often normal behavior. At best, you can be clever on some devices to cause the least amount of drops (or no drops) while still informing the sender to slow its transmission rate or you need to insure there's sufficient bandwidth that sender(s) are not oversubscribed.

An example of the latter, 10, or less, host ports running at 100 Mbps should never overflow a gig uplink. However, 11, or more, hosts might.

Also note, some traffic will not slow down when there's packet drops.

b-aumand Tue, 01/20/2009 - 07:15

Thanks for your response.

But I have these probleme only when th mls qos command is present on the switch.

The transmission slow down with tis command

Joseph W. Doherty Tue, 01/20/2009 - 07:33

Ah, understand.

In that case, it's possible queue sizes differ when MLS QoS is activated. (Also QoS's default WTD.) If traffic is "bursty" and it's nearly offered at maximum interface bandwidth, too small queues might needlessly drop packets.

It's also might be possible you were having drops with MLS QoS not active, but only noticed the drops within the MLS QoS stats. (I do note you mention seeing transmission rate drop. TCP will slow if there are drops.)

You can "tune" QoS queue/buffer parameters. See the QoS chapter for your version of IOS. In the configuration guide, see if there's a section "Allocating Buffer Space to and Setting WTD Thresholds for an Egress Queue-Set".

a.tolstykh Thu, 01/22/2009 - 09:54

Pick any unused interface and apply/remove the following command: "auto qos voip trust" followed by the "no auto qos voip trust". This will resolve throughput issues on 10/100Mbps ports when "mls qos" is activated on the switch.


This Discussion