CP-521

Answered Question
Dec 17th, 2008
User Badges:

I dont get the CP-521 phone to register to my UC500. I have the 12.4.11-XW9 IOS and there is a .bin file which I have put as tftp-server, but what about the load statement under telephony-service, what should I specify as load for the 521 phone?

Correct Answer by Nicholas Matthews about 8 years 7 months ago

Looking closer:


You have your service module IP address defined as your CME address. This is very wrong.


Change:

telephony-service

ip source-address 192.168.200.1 port 2000


ip dhcp pool IPT

default-router 192.168.200.1

option 150 ip 192.168.200.1



hth,

nick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Nicholas Matthews Wed, 12/17/2008 - 05:57
User Badges:
  • Red, 2250 points or more

It isn't required to specify a phone load for a phone to register.


Make sure that you're getting an IP address on the phone, and that the phone is correctly defined on the UC520. Make sure the MAC address matches, and make sure you've got a 'type' command defined under the ephone dn. As well, make sure that you have an actual DN defined or it may look like it's not registered when it actually is.


'debug tftp events' will help you determine if it's downloading the correct files or not.



HTH,

nick

hmglobcom Sat, 12/20/2008 - 10:47
User Badges:

I have specified the mac-address under the ephone and also created an ephone-dn.

I can see when I run "debug tftp events" and debug tftp packets these messages. It seems like the phone doesnt find everything. I have also an 7931 phone that gets an ip address an loads the files from the tftp statement but it won register, I have created the ephone and the ephone-dn as well for that one.

Do you have any suggestions?

Nicholas Matthews Sun, 12/21/2008 - 13:12
User Badges:
  • Red, 2250 points or more

If the debug tftp events show only requests and nothing 'finishes' then you have configuration problems. The .cnf.xml file will not be created on the router until a 'type' command is configured under the ephone configuration.


Every phone needs 3 things:

Button to DN assignment (unless you want a useless phone)

'type xxxx' configured

'mac xxxx.xxxx.xxxx


You can try this as well:

telephony-service

cnf-file per-phone


When the phone looks for SEPxxxxxxxxxxx.cnf.xml, the debug tftp events should show a 'finished' for that file.


hth,

nick

hmglobcom Mon, 12/22/2008 - 05:06
User Badges:

The type command is set to "type 521G" under the ephone with the mac-address of the phone.

In the display of the phone it says "connecting..." and in the debug its not finding the necessary files. And in regards to the 7931 it finds the software and downloads it but wont register.

Is the CP-521SG working with the 12.4(11)XW9

or should I go for 12.4 X7?

Nicholas Matthews Mon, 12/22/2008 - 05:48
User Badges:
  • Red, 2250 points or more

Can you post the ephone config, the ephone-dn config, and the debug tftp events for the 521?

Nicholas Matthews Mon, 12/22/2008 - 09:43
User Badges:
  • Red, 2250 points or more

Try this configuration


telephony-service

cnf per-phone

no create cnf

create cnf


The phone is downloading the default XML file, so it's getting something. It's just not getting a phone specific file.

hmglobcom Mon, 12/22/2008 - 10:23
User Badges:

I get this error, "CNF-FILES: Clock is not set or synchronized, retaining old versionStamps" but is the phone really depending that the clock is correct, I'm setting this up at home locally.

I also added the config, maybe I'm blind and are missing some vital config.



Nicholas Matthews Mon, 12/22/2008 - 11:36
User Badges:
  • Red, 2250 points or more

Try changing this:

ip dhcp pool IPT

option 150 ip 192.168.250.2


hth,

nick

hmglobcom Mon, 12/22/2008 - 12:37
User Badges:

That didnt work either. Any more suggestions?

In my world this should work, I have never seen the CP-521SG before but even the 7931 doesnt work.


Correct Answer
Nicholas Matthews Mon, 12/22/2008 - 12:48
User Badges:
  • Red, 2250 points or more

Looking closer:


You have your service module IP address defined as your CME address. This is very wrong.


Change:

telephony-service

ip source-address 192.168.200.1 port 2000


ip dhcp pool IPT

default-router 192.168.200.1

option 150 ip 192.168.200.1



hth,

nick

hmglobcom Mon, 12/22/2008 - 13:01
User Badges:

And that worked, I knew it was something simple but you go blind after a while. Thank you from the bottomm of my heart, you saved my christmas.

Have a nice christmas and take good care!

hmglobcom Mon, 12/22/2008 - 13:14
User Badges:

One last question, one of the CP-521 phones gets an error saying SPCP Register Token Rejected and the tftp output is added as an attachment. Read that someone else had a similar problem and was solved by tftp'ing new firmware to UC500. But I have the latest.

I have removed and added the ephone and ephone-dn and also did a factory reset on the phone.

Any suggestions?


Nicholas Matthews Mon, 12/22/2008 - 13:34
User Badges:
  • Red, 2250 points or more

SPCP is a modified SCCP protocol for the UC520.


You will need to run 12.4(11)XW8 or later on a UC520. This should work after that, however.

hmglobcom Mon, 12/22/2008 - 13:48
User Badges:

And I run 12.4(11)XW9 and I have two other phones that works without that issue. Could it be broken or shall I try to downgrade the IOS or report the phone as broken?


Actions

This Discussion