Help configuring QoS on ISR 1861

Unanswered Question
Dec 18th, 2008

Could someone help me get QoS working on an 1861 router please? I have one of these on a remote site connected to an MPLS network via a BT supplied CE router.

When I place a call from an IP phone on the 1861 to a phone at the main site and I sniff the ip phone port on the 1861 I can see EF packets being placed on the LAN by the phone and I also see EF frames coming back in from the ip phone on the main site. From this point of view all looks OK.

However, if I go to the main site and sniff the ip phone port and place a call to the remote site I see EF frames coming on to the LAN from the local ip phone but dont get any EF frames from the remote site.

BT say that their CE routers are configured to trust any packets coming from our routers so the problem must be with the QoS config on my 1861. My 1861 is connected to BT's CE router via its f0/0 interface.

The IP Phone interfaces are configure as:

interface FastEthernet0/1/0 to 0/1/7

description ***IP Phone and Client Data Port***

switchport access vlan 20

switchport voice vlan 10

auto qos voip trust

service-policy output AutoQoS-Policy-Trust

Interface f0/0 is configured as follows:

description ***Link to BT MPLS Router***

ip address 192.168.15.193 255.255.255.192

duplex auto

speed auto

service-policy output AutoQoS-Policy-Trust

The auto generated service police is:

class-map match-any AutoQoS-VoIP-RTP-Trust

match ip dscp ef

class-map match-any AutoQoS-VoIP-Control-Trust

match ip dscp cs3

match ip dscp af31

!

policy-map AutoQoS-Policy-Trust

class AutoQoS-VoIP-RTP-Trust

priority percent 70

class AutoQoS-VoIP-Control-Trust

bandwidth percent 5

class class-default

fair-queue

!

Since sniffing the ports I have added the line "auto qos voip trust" on interface F0/0 but havent had a chance to test again as yet.

Any help would be appreciated.

Thanks,

Paul.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nicholas Matthews Thu, 12/18/2008 - 20:21

Normally there are two situations that cause packets to get marked down:

Over subscribing a link, and the extra packets are marked to BE (0).

A switch with mls qos configured, but the packets are coming in on a port without a 'trust' configuration.

Actions

This Discussion