RIP reditribution into EIGRP

Unanswered Question
Dec 18th, 2008

I am trying to redistribute a RIP route to an EIGRP process to no avail. Below are the commands:

router eigrp 65204

redistribute rip metric 1000000 10 255 1 1500 route-map rip-to-eigrp

network 10.33.94.120 0.0.0.3

network 10.33.94.128 0.0.0.3

no auto-summary

router rip

version 2

passive-interface Vlan10

passive-interface Vlan11

network 10.0.0.0

distribute-list prefix HK in Vlan10

no auto-summary

access-list 50 permit 10.170.0.254

route-map rip-to-eigrp permit 10

match ip route-source 50

HK02#sh ip route rip

198.140.33.0/32 is subnetted, 1 subnets

R 198.140.33.2 [120/1] via 10.170.0.254, 00:00:10, Vlan10

HK02#sh ip eigrp topo 198.140.33.2

% IP-EIGRP (AS 65204): Route not in topology table

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Giuseppe Larosa Thu, 12/18/2008 - 09:57

Hello Etienne,

what if you use match ip next-hop 50 instead inside the route-map ?

or even if you try to match directly the prefix 198.140.33.2/32

2)

you have passive-interface vlan10 so you are trying to learn a prefix without providing routes to your RIP neighbor

Hope to help

Giuseppe

Tshi M Thu, 12/18/2008 - 10:02

Hi Giuseppe,

Thanks for the quick reply. What I am trying to do is redistribute the learned RIP address to my internal EIGRP. The device is learing the RIP information just fine but it cannot redistribute it into EIGRP.

Giuseppe Larosa Thu, 12/18/2008 - 10:07

Hello Etienne,

I wonder if RIP has the concept or route-source or it is missing it.

for example an OSPF LSA has a clear route-source the OSPF RID of the router that generated it.

With RIP data structures are changed at every hop and so I think it is more appropriate to match on the ip next hop that appears as via x.x.x.x instead of looking for a route-source

The practical effect should be the same

Hope to help

Giuseppe

Tshi M Thu, 12/18/2008 - 10:32

Hi Giuseppe,

yes, it seems to have that capability:

HK02(config-route-map)#match ip ?

address Match address of route or match packet

next-hop Match next-hop address of route

route-source Match advertising source address of route

Tshi M Thu, 12/18/2008 - 11:02

Well it is not showing in the topology table:

HK02#sh ip eigrp topo 198.140.33.2

% IP-EIGRP (AS 65204): Route not in topology table

but it shows up when i do show ip route 198.10.33.2 from another router.

HK00#sh ip route 198.140.33.2

Routing entry for 198.140.33.2/32

Known via "eigrp 65204", distance 170, metric 5376

Tag 12, type external

Redistributing via eigrp 65204

Last update from 10.33.94.121 on GigabitEthernet0/1, 00:08:26 ago

Routing Descriptor Blocks:

* 10.33.94.121, from 10.33.94.121, 00:08:26 ago, via GigabitEthernet0/1

Route metric is 5376, traffic share count is 1

Total delay is 110 microseconds, minimum bandwidth is 1000000 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 1/255, Hops 1

Route tag 12

So, it is being distributed via into eigrp.

Tshi M Thu, 12/18/2008 - 10:38

I also tried to use "next hop" to no avail either.

Richard Burts Thu, 12/18/2008 - 11:02

I do not believe that there is a problem with your route map and believe that the route is probably being redistributed. The problem is with how you are looking for it. I set up a lab to duplicate your issue. When I issue the command sh ip eigrp topo 198.140.33.2 I get the same result of route not in table. But when I add the mask to the request sh ip eigrp topo 198.140.33.2 255.255.255.255 then I see that the route is in the table.

I suggest that you retry the show ip eigrp topology command and specify the mask.

HTH

Rick

Tshi M Thu, 12/18/2008 - 11:05

Hi rburst,

It looks like we posted at the same time. Yes, it shows up when you had the subnet.

Actions

This Discussion