Configuring switches to support wireless bridges

Unanswered Question
Dec 18th, 2008


I have a customer who has two non-Cisco 802.11g wireless bridges linking a small building to a larger buidling housing the data centre.

They complained about poor performance for the users in the small building. Looking at the switch ports supporting the bridges I noticed that they were set to auto-negotiate and had negotiated 100Mbps full duplex.

The port supporting the bridge in the main building is showing a number of output buffer failures although this is less than 0.001% of the total number of packets sent.

My suspicion is that the switch is sending more data than the wireless network can support at certain times of the day.

I could drop the speed of the switch ports to 10Mbps but am reluctant to do this as the wireless network is running at 24Mbps and I want to try to make the most of this speed.

I am going to try running the switch ports a 100 Mbps half duplex to see if that makes a difference but am wondering if anyone can suggest any other solutions I can try.

The switches supporting the link are Catalyst 3550 10/100 with the latest basic image. This stops me doing anything too clever such as packet shaping.

Any suggestions welcome.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
CFayNTAdmin83 Thu, 12/18/2008 - 13:39

Hi. I thought about your situation and I recommend to keep the port at 100 MBPS full duplex (or auto). If you're having speed / performance problems, I'd recommend to log into the bridges and see what the rssi signal values are compared to the bridges data rates. Also, depending on if vlans are used, you may need to set the 3550 port to "switchport mode trunk" and "switchport trunk encapsulation dot1q". What kind of bridges are you using by chance?

jeff.kish Thu, 12/18/2008 - 14:59

Unless the input buffer for the bridge is dropping packets, it shouldn't be a traffic overflow issue. If anything, the data rate of the bridge might drop throughout the day. Try monitoring the speed of the link when they complain about slowness.

Keep in mind that bridges running 24Mbps run close to 12Mbps, so setting your switch to 10Mbps isn't a bad idea to see if that helps. I would do waht I can to keep it at 100Mbps though.

Why is the bridge only running at 24Mbps? Can you install larger antennas to increase the speed to 54? It might just be that the wireless bandwidth is too small.

Finally, consider upgrading to Cisco bridges :D


James Hawkins Thu, 12/18/2008 - 15:12

Thanks for the responses. The bridges were installed by another supplier and I was not involved in the design or data rate selection. It would not be easy to change the antennas as they are externally mounted on a high part of the building.

The customer is getting the login details for the bridges from the supplier. I will see if this will shed any light on the situation.

wesleyterry Fri, 12/19/2008 - 19:52

This could simply be an interference problem. Since you refer to the antennas being high on the roof, how far apart are these buildings? Using 802.11G for bridging buildings across a town opposed to across a parking lot might subject the link to random interference.

Maybe simple changing channels will help the overall performance of the link?

James Hawkins Sun, 12/21/2008 - 13:11

Thanks for the response.

The customer is getting the supplier of the bridges to check how they are performing. I will post their findings here.


This Discussion



Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode