MP-BGP/MPLS on Cisco 870 series

Unanswered Question
Dec 19th, 2008

I have a Cisco 871 router running IOS 12.4(22)T. I have advanced IP feature set.

Cisco feature navigator indicates that MP-BGP MPLS is supported by this release on this platform. All I need is basic MPLS/GRE tunnel with static labels to be terminated on a remote PE.

When I try to configure a L3VPN, I do not find any command to do it.

How can I configure it ?

Thanks

Farid

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Sat, 12/20/2008 - 23:36

Hello Farid,

at the end of the list of features for 12.4(22)T in FN appears the following message:

"Some features are dependent on product model, interface modules (i.e. Line Cards & Port Adapters), and/or require a software feature license. Click here for more information."

Try the following:

conf t

ip vrf mytest

if this command is not accepted you cannot run a VRF over a GRE tunnel.

You can try to configure a GRE tunnel that is in VRF only on the other side.

Hope to help

Giuseppe

convertel Mon, 12/22/2008 - 02:07

Hi Giuseppe,

Thanks. Indeed, I can create the VRFs as you mentionneded but I cannot enable the MP-BGP which is a component of the L3VPN as shown below:

cisco871-cpe#conf terminal

Enter configuration commands, one per line. End with CNTL/Z.

cisco871-cpe(config)#router bgp 100

cisco871-cpe(config-router)#address-family vpnv4 unicast

^

% Invalid input detected at '^' marker.

cisco871-cpe(config-router)#

cisco871-cpe(config-router)#

ip cef

ip vrf vpn1

rd 100:1

route-target export 100:1

route-target import 100:1

!

interface Tunnel1

ip address 1.1.1.1 255.255.255.0

ip mtu 1400

tunnel source FastEthernet4

tunnel destination 10.81.101.4

!

router bgp 100

no synchronization

bgp log-neighbor-changes

neighbor 10.81.101.4 remote-as 1

neighbor 10.81.101.4 update-source FastEthernet4

no auto-summary

!

Giuseppe Larosa Mon, 12/22/2008 - 05:01

Hello,

you may need a command under router bgp

router bgp 100

no bgp default ipv4-unicast

this moves BGP4 to BGP4+ and allows to use address families

then don't add the unicast parameter

address-family vpnv4

try in this way

Hope to help

Giuseppe

Actions

This Discussion