Register IP Phone

Answered Question
Dec 19th, 2008
User Badges:

Hello,


I need to know how to register a IP Phone on the call manager express, I need to do something on the IP Phone?


My IP Phone 7906 is configured with static IP, TFTP server is the ip address of the Call Manager, but the ip phone tell 'Registration Rejected: No conf'


I have used QCT software to start a quick conf on my Call Manager but I don't arrive to register ip phone on my call manager.


Regards



Correct Answer by Nicholas Matthews about 8 years 5 months ago

ephone 1

mac 0022.90BC.20A8

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jesse Drohen Fri, 12/19/2008 - 08:46
User Badges:
  • Cisco Employee,

A very important command is create cnf-files. Without that the CME will not create xml files to hand out to the phone when it attempts to register. You also need to ensure that any file that you tell the router it has with the tftp-server flash: command is actually in the flash of the router. If you are unable to get your phone to register debug tftp events is a good debug so see what the phone is requesting and where it is failing. A useful show command is show telephony-service tftp-bindings. This will show all files that are available to a phone using tftp.


2600XM_CME#sh run

Building configuration…


Current configuration : 1240 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 2600XM_CME

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$ZYdg$wAiT47.cKoEBUitfgZgnR/

!

no aaa new-model

!

resource policy

!

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

ip dhcp excluded-address 172.16.1.1 172.16.1.10

!

ip dhcp pool 172

network 172.16.1.0 255.255.255.0

default-router 172.16.1.1

domain-name cisco.com

option 150 ip 172.16.1.10

!

!

no ip domain lookup

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 172.16.1.10 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

no dce-terminal-timing-enable

!

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

!

ip http server

no ip http secure-server

!

!

tftp-server flash:P00307020200.sbn

tftp-server flash:P00307020200.bin

tftp-server flash:P00307020200.loads

tftp-server flash:P00307020200.sb2

!

control-plane

!

!

!

!

telephony-service

load 7960-7940 P00307020200

max-ephones 10

max-dn 10

ip source-address 172.16.1.10 port 2000

create cnf-files

!

!

ephone-dn 1

number 1000

!

!

ephone 1

mac-address 0011.aaaa.8500

button 1:1

!

!

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

!

end

Nicholas Matthews Fri, 12/19/2008 - 09:35
User Badges:
  • Red, 2250 points or more

Try these two things:


telephony-service

auto-reg-ephone


As well, make sure you have something very similar to this configured:


ephone-dn x dual

number x


ephone x

mac xxxx.xxxx.xxxx

type 7906

button 1:x



Try both of these things and I think it will resolve your problem.


p.maillot Fri, 12/19/2008 - 10:18
User Badges:

Always the same problem, start > configuring IP > resetting


See the debug


CallManager#

Dec 19 18:50:42.462: TFTP: Looking for CTLSEP002290BC20A8.tlv

Dec 19 18:50:42.538: TFTP: Looking for SEP002290BC20A8.cnf.xml

Dec 19 18:50:42.582: TFTP: Looking for XMLDefault.cnf.xml

Dec 19 18:50:42.582: TFTP: Opened system:/its/XMLDefault.cnf.xml, fd 0, size 1548 for process 237

Dec 19 18:50:42.590: TFTP: Finished system:/its/XMLDefault.cnf.xml, time 00:00:00 for process 237

Dec 19 18:50:48.918: TFTP: Looking for P00307020200.loads

Dec 19 18:51:02.106: TFTP: Looking for CTLSEP002290BC20A8.tlv

Dec 19 18:51:02.178: TFTP: Looking for SEP002290BC20A8.cnf.xml

Dec 19 18:51:02.234: TFTP: Looking for XMLDefault.cnf.xml

Dec 19 18:51:02.234: TFTP: Opened system:/its/XMLDefault.cnf.xml, fd 0, size 1548 for process 237

Dec 19 18:51:02.242: TFTP: Finished system:/its/XMLDefault.cnf.xml, time 00:00:00 for process 237

Dec 19 18:51:03.146: %IPPHONE-6-REG_ALARM: 25: Name=SEP002290BC20A8 Load= SCCP11.8-3-2S Last=Initialized

Dec 19 18:51:04.382: TFTP: Looking for CTLSEP002290BC20A8.tlv

Dec 19 18:51:04.454: TFTP: Looking for SEP002290BC20A8.cnf.xml

Dec 19 18:51:04.534: TFTP: Looking for XMLDefault.cnf.xml

Dec 19 18:51:04.534: TFTP: Opened system:/its/XMLDefault.cnf.xml, fd 0, size 1548 for process 237

Dec 19 18:51:04.538: TFTP: Finished system:/its/XMLDefault.cnf.xml, time 00:00:00 for process 237

Dec 19 18:51:10.998: TFTP: Looking for P00307020200.loads


ephone-dn 5 dual-line

number 100 secondary 4085551000

label 100

description User Name

name CISCO

call-forward busy 600

call-forward noan 600 timeout 15

corlist incoming user900-international


ephone 1

video

mac-address 0000.0000.0001

username "100" password 0000

type 7960

button 1:5

pin 0000






jimnycricket65 Wed, 01/07/2009 - 18:58
User Badges:

Hi. Can you tell me where I am trying the two things? I am not all that tech savy.

Actions

This Discussion