Gigabit Link issue between 2960 and 3500XL

Unanswered Question
Dec 19th, 2008

Unable to successfully link gigabit adapters over MM fiber between a Cisco 3500XL switch and a new Cisco 2960 switch. Have tried configuring ports in sevral modes but none seem to work between the older Gigabit SX module an dthe newer SFP-SX module.

Tried the following:

>switchport mode dynamic desirable

>switchport mode access

>switchport mode trunk

>switchort trunk encap dot1q

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Giuseppe Larosa Fri, 12/19/2008 - 12:14

Hello Barron,

try to add

swichport nonegotiate

in interface configuration mode on the C2960

Hope to help


brascoe Fri, 12/19/2008 - 12:41

thanks :)

i seem to recall that i ran into this exact issue before and that was the fix...

thanks again!

viyuan700 Fri, 12/19/2008 - 12:28

I saw SFP SX for 2960 is working at wavelngth 850.

I am trying to get it for 3500 XL, if you have info can u tell me is older Gigabit SX is working at 850nm (i tried to see with Gigabit SX i got for some other product that it is working at 1310nm)

If they are at different wavelength it is not going to work even though both are MM.

Giuseppe Larosa Fri, 12/19/2008 - 12:42

Hello Vishwamurti,

the right GBIC for SX in first wavelength window has the following part number

WS-G5484= SX 850 nm

WS-G5486= this is LX/LH and in the second window 1300 nm

see the compatibility matrix

I agree with you that two GBICs using different wavelengths cannot communicate.

Hope to help



This Discussion