Weired RR issue for vpnv4 routes

Unanswered Question
Dec 20th, 2008

We are having 2*RR for MPLs vpn routes. Any PE is having two neighborships one with each RR. But I am facing a one weird issue that update of routes of some vrfs are only forwarding to one RR not to another RR. Can anyone tell me why it is happening?


shivlu jain

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Giuseppe Larosa Sat, 12/20/2008 - 23:46

Hello Shivlu,

I've understood you have two RR Servers in your network for address-family vpnv4 that are serving a population of PE nodes.

If I understand correctly one of your RRS is missing some vpnv4 routes associated to some VRFs.

Verify if there are any form of route filtering based on route target value inbound on that RRS or outbound on PE nodes.

There is any route-map applied in AF vpnv4 in RRS or in PE nodes ?

Or are you complaining that for some VRFs some PE nodes receive only routes reflected by a single RRS ?

If the RRS are placed in different points of your topology, there is a chance that one has a better IGP metric to some PE nodes.

May you provide more details with an example of show ip bgp vpnv4 all on source PE, the two RRS, a remote PE ?

What is the memory usage on the second RRS the one with missing routes ?

Hope to help


guruprasadr Sun, 12/21/2008 - 23:53

HI Shiv,

Adding to the 'Giuseppe' post,

I am wondering, some Inbound Control List if any applied in your 2nd RR matching the specific Customer RT.

Kindly confirm the above.

Best Regards,

Guru Prasad R

shivlu jain Fri, 12/26/2008 - 05:11

hi Giuseppe

Thanks for your reply. You are very much right but I have already checked that & that was not an issue.

My problem has been resolved and I found last IOS bug from cisco end. But the problem taught me very good lesson. I posted the all details inmy blog. Kindly check


shivlu jain

guruprasadr Fri, 12/26/2008 - 06:26

Dear Shiv,

Thanks for updating the Information.


Guru Prasad R

Giuseppe Larosa Fri, 12/26/2008 - 07:35

Hello Shivlu,

good news you have solved this issue.

May I ask you the router platform, IOS release, and Cisco bug-id to make this thread even more useful?

Best Regards


guruprasadr Sat, 12/27/2008 - 22:43

HI Shiv,

We are running our VPN-RR with standard IOS-c7301-k91p-mz.122-18.S7.bin

The Internet-RR with standard IOS-c7301-p-mz.122-18.S3.bin

Use: cisco 7301 (NPE) processor

Hope I am Informative.

Best Regards,

Guru Prasad R


This Discussion