CW LMS portal URL does not change aft hostname changed

Unanswered Question
Dec 20th, 2008
User Badges:

Hi Experts,


I have run the change hostname.pl script in bin folder as instructed by the Common Services user guide.


However, CW LMS Portal url doesn't change according to the new hostname. Is it normal or do I left out any necessary step?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Sat, 12/20/2008 - 10:03
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please provide a screenshot illustrating exactly what has not been changed.

jeeyishyuan Sat, 12/20/2008 - 19:16
User Badges:

Hi jclarke,


The old hostname is iteserver10.

The new hostname is ciscoworkProd.


However, aft running hostnamechange.pl, the CW LMS portal url remained the old hostname upon launching.


I have attached the screen shot of the web browser when launching it.



Attachment: 
Joe Clarke Sat, 12/20/2008 - 23:05
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I assume you arrived at this error by clicking on the CiscoWorks desktop icon? If so, the URL pointed to by that shortcut does not change. You will need to create a new URL shortcut. To do this, right-click on the desktop, and select New > Shortcut. Enter the location for the shortcut as http://ciscoworksprod:1741/ . You can change the shortcut icon to the CiscoWorks icon by pointing the icon path to NMSROOT\MDC\etc\ciscoWorks.ico.

jeeyishyuan Sun, 12/21/2008 - 06:05
User Badges:

Hi jclarke,


I have created the shortcut. But it seems like I am still not able to view the login page from the new url. Web browser still prompting "The page cannot be displayed" error.


I tried to start and stop the Daemon manager for several times but problem remained unsolved.


I have attached the running result for hostnamechange.pl script. Please advise. Thanks!


Regards

Yi Shyuan



Joe Clarke Sun, 12/21/2008 - 09:39
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Since the URL in the browser is clearly the old hostname, how did you get to this error? If the new shortcut points to the new hostname, and ciscoworksprod is the actual COMPUTERNAME of this server, then you should get a successful connection.


Are you getting the same error when the browser is showing the URL to be http://ciscoworksprod:1741 ?

Joe Clarke Sun, 12/21/2008 - 10:33
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post the output of the pdshow command.

Joe Clarke Sun, 12/21/2008 - 21:59
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

From a DOS prompt, run the command pdshow, and capture the output.

Joe Clarke Sun, 12/21/2008 - 23:38
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

According to this, everything is running properly. You should be able to go to http://ciscoworksprod:1741/ on the server itself, and receive the login screen provided that really is the hostname of the server (i.e. in the output of the DOS command "SET" the value of COMPUTERNAME is CISCOWORKSPROD). You can also try connecting to http://IPADDR:1741 where IPADDR is the IP address of the server.

jeeyishyuan Sun, 12/21/2008 - 23:42
User Badges:

I tried using http://IPADDR:1741. It gave me a blank screen immediately aft login. LMS Portal works fine when I tried to change the hostname back to the old one.

Joe Clarke Sun, 12/21/2008 - 23:46
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

If the old hostname still works, then you have not properly set the hostname on the server. Please post the output of the DOS SET command, the NMSROOT\lib\classpath\md.properties, and the NMSROOT\MDC\etc\regdaemon.xml.

Joe Clarke Sun, 12/21/2008 - 23:59
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

According to this, LMS thinks the hostname is still iteserver10. You need to re-run the hostnamechange.pl script:


NMSROOT\bin\perl NMSROOT\bin\hostnamechange.pl -ohost iteserver10 -nhost ciscoworkprod


You need to run this script as a local Administrator. Then you need to reboot.

Joe Clarke Mon, 12/22/2008 - 06:40
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Good, these look fine. If you reboot, you should be able to access LMS now.

jeeyishyuan Mon, 12/22/2008 - 19:58
User Badges:

Hi jclarke,


Are you saying to reboot the server after running hostnamechange.pl script?


Regards

Yi Shyuan

Joe Clarke Mon, 12/22/2008 - 20:18
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Yes.

jeeyishyuan Tue, 12/23/2008 - 02:09
User Badges:

Hi jclarke,


I got a blank page upon login to CW LMS portal. Please refer to the screen shot.


Thanks and Regards,

YS



Attachment: 
Joe Clarke Tue, 12/23/2008 - 09:44
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post the NMSROOT\MDC\tomcat\logs\stdout.log.

Joe Clarke Tue, 12/23/2008 - 10:32
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

According to this, everything is fine. Try accessing LMS from an external client. If you're using IE, make sure the LMS server is in your list of Trusted Sites.

Actions

This Discussion