Router MPLS 2621XM

Unanswered Question
Dec 20th, 2008

I need to load an IOS that supports MPLS for the 2621XM router. Does anyone have a suggested IOS I should run? I am setting up a lab for the CCNP ISCW certification test.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Charlie Mayes Sat, 12/20/2008 - 14:09

I have this one loaded but do not see a MPLS IP option anywhere. I have already enabled CEF with ip cef. Am I missing something?

c2600-advipservicesk9-mz.124-10.bin

viyuan700 Sat, 12/20/2008 - 14:21

on an interface you dont have mpls ip command / mpls lable protocoltype

viyuan700 Sat, 12/20/2008 - 14:30

go to config mode

then enter to any interface

with command like

int f0/0 or f0/1 etc then

you will have mode like

Hostname(config-if)#?

on that interface type ? hit enter you will see for mpls ip if it is there u have that feature

Charlie Mayes Sat, 12/20/2008 - 14:33

I have done that and I don't have that option at all. I check it before and thought it was weird. What now?

viyuan700 Sat, 12/20/2008 - 14:38

do you have mpls ip in config mode

Hostname(config)#?

do you have mpls ip here

Charlie Mayes Sat, 12/20/2008 - 15:11

!

hostname HQ2

!

boot-start-marker

boot-end-marker

!

enable password cisco

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication login VPNAUTH local

aaa authorization network VPNAUTH local

!

aaa session-id common

clock timezone NewYork -5

clock summer-time NewYork date Apr 6 2003 2:00 Oct 26 2003 2:00

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

!

!

no ip domain lookup

ip domain name ike

!

!

!

!

!

!

!

!

!

!

!

!

!

!

crypto pki trustpoint TP-self-signed-1594146880

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1594146880

revocation-check none

rsakeypair TP-self-signed-1594146880

!

!

crypto pki certificate chain TP-self-signed-1594146880

certificate self-signed 01

3082023F 308201A8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

69666963 6174652D 31353934 31343638 3830301E 170D3032 30333031 30343537

31365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35393431

34363838 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

8100CE63 AFC8504A 697DA5EF 4535DAAC C81B5528 FAE58751 992F9BA7 B9180F72

EC017F4D 7A0E1C1E 4883D078 EA471F98 F0AF26CE 7A05870D 6EEF4400 0CE7C4F5

F6667021 1212A7E9 D25B27E2 FADDD347 CFCB75F4 8F19DF1F CE4AB46D E337D740

5274998A 2111A4DA AD5E1432 04817AD7 F8B2438F 2C890429 ABD34ABA B1EE1DE6

F6EB0203 010001A3 67306530 0F060355 1D130101 FF040530 030101FF 30120603

551D1104 0B300982 07485132 2E696B65 301F0603 551D2304 18301680 14D927D5

1E2F2AA4 1D4C3034 76EADB03 3A1B63C4 29301D06 03551D0E 04160414 D927D51E

2F2AA41D 4C303476 EADB033A 1B63C429 300D0609 2A864886 F70D0101 04050003

81810070 07191AD0 5C074CD2 18211AFE DDA175C5 4DD831E6 6A1C60B2 1D14F06A

E79A07CD EABFD1C0 DC55A8FC E0DBC398 1F606933 D0CCE88F 698135FE 56914C15

F59EAE92 570DD79E EA57E640 877085B2 8B08387B 0358F382 A03B269B 04BE0578

4A493D1A 5E09BFBD 6B41BD5C 4CBBA35D EA527A8E 81C0F455 2F1BA836 B9345143 3C9565

quit

username

username

username

username

username

!

!

!

crypto isakmp policy 10

encr aes 256

authentication pre-share

group 2

crypto isakmp keepalive 30 5

crypto isakmp xauth timeout 60

!

crypto isakmp client configuration group ciscogroup

key ciscogroup

pool VPNCLIENTS

acl 100

netmask 255.255.255.0

!

!

crypto ipsec transform-set mytrans esp-3des esp-sha-hmac

!

crypto dynamic-map mymap 10

set transform-set mytrans

reverse-route

!

!

crypto map mymap client authentication list VPNAUTH

crypto map mymap isakmp authorization list VPNAUTH

crypto map mymap client configuration address respond

crypto map mymap 10 ipsec-isakmp dynamic mymap

!

!

!

!

interface Loopback0

ip address 172.16.3.1 255.255.255.0

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface FastEthernet0/1

description Outside interface

ip address dhcp

duplex auto

speed auto

crypto map mymap

!

router eigrp 1

network 172.16.0.0

no auto-summary

!

router rip

version 2

network 192.168.0.0

no auto-summary

!

ip local pool VPNCLIENTS 192.168.0.50 192.168.0.75

ip route 192.168.0.0 255.255.255.0 FastEthernet0/1

!

!

ip http server

ip http secure-server

!

access-list 100 permit ip 172.16.0.0 0.0.255.255 any

access-list 100 permit ip 192.168.0.0 0.0.255.255 any

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password cisco

transport input ssh

!

!

end

Charlie Mayes Sat, 12/20/2008 - 15:12

HQ2#sh version

Cisco IOS Software, C2600 Software (C2600-ADVIPSERVICESK9-M), Version 12.4(10),

RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Wed 16-Aug-06 01:42 by prod_rel_team

ROM: System Bootstrap, Version 12.2(7r) [cmong 7r], RELEASE SOFTWARE (fc1)

HQ2 uptime is 6 days, 8 hours, 10 minutes

System returned to ROM by power-on

System restarted at 09:59:53 NewYork Sun Dec 14 2008

System image file is "flash:c2600-advipservicesk9-mz.124-10.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

[email protected].

Cisco 2621XM (MPC860P) processor (revision 1.0) with 127308K/3764K bytes of memo

ry.

Processor board ID JAE073416L8

M860 processor: part number 5, mask 2

2 FastEthernet interfaces

1 Serial interface

32K bytes of NVRAM.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Charlie Mayes Sat, 12/20/2008 - 16:19

Yeah I can agree this is weird. If you think for anything else let me know.

Charlie Mayes Sat, 12/20/2008 - 20:06

Hey I found a IOS that works for the 2621 MPLS lab finally.

c2600-adventerprisek9-mz.123-26.bin

Thanks for all your help.

viyuan700 Sat, 12/20/2008 - 20:21

pls see the other thread looks like whatever edison has said is true.

As the link i sent you say 2621XM support but sometimes there are so many things behind those simple words which we cannot decipher.

Actions

This Discussion