Prefix FXO line

Answered Question
Dec 21st, 2008

Hello,

I Have a FXO card and I want that the extension 100 can take this line.

How to create a prefix to take this line, for example I want to dial 0 to take this line? And how to program a key on the IP Phone to take this line?

voice-port 0/3/0

connection plar 100

Regards

I have this problem too.
0 votes
Correct Answer by hassan_oudeh about 7 years 11 months ago

ok then forward all the dialed digits.

for example for loca calls you will dial 0 then the 7 digits number as below:

dial-peer voice 10 pots

destination-patter 0[2-9]......

port 0/3/0

forward digits 7

try that

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Chris Deren Sun, 12/21/2008 - 08:07

You need to create a dial peer in order to control outboud calls, i.e.

dial-peer voice 1 pots

destination-pattern 0

port 0/3/0

forward-digits 1

connection plar controls inboud destination, so if a call arrives on this port from the connected device (PSTN) it will be forwarded to extension 100.

HTH,

Chris

p.maillot Mon, 12/22/2008 - 00:17

Now when I dial the number 0, the call try to take the port 0/3/3 and after the port 0/3/2 and after again the port 0/3/1 before to arrive at the correct line at 0/3/0.

The call don't take directly the port 0/3/0, why?

Regards

hassan_oudeh Mon, 12/22/2008 - 03:31

plz post your full configuration, you should have something conflicting the mentioned dial-peer.

thx

p.maillot Mon, 12/22/2008 - 05:19

See my conf.

Now I have an another problem when I try to take my line on port 0/3/0 I can see an activity on this port (green led) but no tone.

!

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

h323

sip

registrar server expires max 3600 min 3600

!

!

voice class codec 1

codec preference 1 g711ulaw

!

!

!

!

!

!

!

!

!

!

!

!

voice translation-rule 9

rule 1 /^911$/ /911/

rule 2 /^0\(.*\)/ /\1/

!

controller E1 0/0/0

!

controller E1 0/0/1

!

class-map match-all L3-to-L2_VoIP-Cntrl

match ip dscp af31

class-map match-all L3-to-L2_VoIP-RTP

match ip dscp ef

class-map match-all SIP

match protocol sip

class-map match-all RTP

match protocol rtp

!

!

policy-map EthOut

class RTP

policy-map output-L3-to-L2

class L3-to-L2_VoIP-RTP

set cos 5

class L3-to-L2_VoIP-Cntrl

set cos 3

!

!

!

!

!

interface Loopback0

ip address 10.1.10.2 255.255.255.0

!

interface GigabitEthernet0/0

description $FW_OUTSIDE$

ip address dhcp

ip access-group 101 in

ip nat outside

shutdown

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

ip address 10.10.10.1 255.255.255.0

ip access-group 100 in

no ip mroute-cache

duplex auto

speed auto

media-type rj45

h323-gateway voip bind srcaddr 10.10.10.1

!

interface Integrated-Service-Engine3/0

no ip address

no keepalive

!

!

!

ip http server

ip http authentication local

ip http secure-server

ip http path flash

!

access-list 100 remark auto generated by SDM firewall configuration

access-list 100 remark SDM_ACL Category=1

access-list 100 deny ip 10.0.0.0 0.0.0.255 any

access-list 100 deny ip host 255.255.255.255 any

access-list 100 deny ip 127.0.0.0 0.255.255.255 any

access-list 100 permit ip any any

access-list 101 remark auto generated by SDM firewall configuration

access-list 101 remark SDM_ACL Category=1

access-list 101 deny ip 20.0.0.0 0.0.0.255 any

access-list 101 permit udp host 205.152.0.20 any

access-list 101 permit icmp any any echo-reply

access-list 101 permit icmp any any time-exceeded

access-list 101 permit icmp any any unreachable

access-list 101 deny ip 10.0.0.0 0.255.255.255 any

access-list 101 deny ip 172.16.0.0 0.15.255.255 any

access-list 101 deny ip 192.168.0.0 0.0.255.255 any

access-list 101 deny ip 127.0.0.0 0.255.255.255 any

access-list 101 deny ip host 255.255.255.255 any

access-list 101 deny ip host 0.0.0.0 any

access-list 101 deny ip any any log

!

!

tftp-server flash:P00307020200.sbn

tftp-server flash:P00307020200.bin

tftp-server flash:TERM70.7-0-1-0s.LOADS

tftp-server flash:TERM70.DEFAULT.loads

tftp-server flash:TERM71.DEFAULT.loads

tftp-server flash:cnu70.2-7-4-134.sbn

tftp-server flash:Jar70.2-9-0-117.sbn

tftp-server flash:CVM70.2-0-0-112.sbn

!

control-plane

!

!

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

voice-port 0/2/0

connection plar opx 601

caller-id enable

!

voice-port 0/2/1

connection plar opx 601

caller-id enable

!

voice-port 0/2/2

connection plar opx 601

caller-id enable

!

voice-port 0/2/3

connection plar opx 601

caller-id enable

!

voice-port 0/3/0

connection plar 100

caller-id enable

!

voice-port 0/3/1

connection plar opx 601

caller-id enable

!

voice-port 0/3/2

connection plar opx 601

caller-id enable

!

voice-port 0/3/3

connection plar opx 601

caller-id enable

!

voice-port 4/0/0

!

voice-port 4/0/1

!

voice-port 4/0/2

!

voice-port 4/0/3

!

voice-port 4/0/4

!

voice-port 4/0/5

!

voice-port 4/0/6

!

voice-port 4/0/7

p.maillot Mon, 12/22/2008 - 05:22

dial-peer cor custom

name internal

name local

name domestic

name international

name 900

name 976

!

!

dial-peer cor list call-internal

member internal

!

dial-peer cor list call-local

member local

!

dial-peer cor list call-domestic

member domestic

!

dial-peer cor list call-international

member international

!

dial-peer cor list call-900

member 900

!

dial-peer cor list call-976

member 976

!

dial-peer cor list user-internal

member internal

!

dial-peer cor list user-local

member internal

member local

!

dial-peer cor list user-domestic

member internal

member local

member domestic

!

dial-peer cor list user-international

member internal

member local

member domestic

member international

!

dial-peer cor list user900-internal

member internal

member 900

member 976

!

dial-peer cor list user900-local

member internal

member local

member 900

member 976

!

dial-peer cor list user900-domestic

member internal

member local

member domestic

member 900

member 976

!

dial-peer cor list user900-international

member internal

member local

member domestic

member international

member 900

member 976

!

!

dial-peer voice 3 pots

corlist outgoing call-local

description ** T1 PRI pots dial-peer **

destination-pattern 9T

!

dial-peer voice 4 pots

corlist outgoing call-domestic

description ** T1 PRI pots dial-peer **

destination-pattern 9T

!

dial-peer voice 5 pots

corlist outgoing call-international

description ** T1 PRI pots dial-peer **

destination-pattern 900T

!

dial-peer voice 6 pots

corlist outgoing call-900

description ** T1 PRI pots dial-peer **

destination-pattern 91900.......

!

dial-peer voice 7 pots

corlist outgoing call-976

description ** T1 PRI pots dial-peer **

destination-pattern 91976.......

!

dial-peer voice 8 pots

description ** T1 PRI pots dial-peer **

incoming called-number .

direct-inward-dial

!

dial-peer voice 9 pots

description ** T1 PRI pots dial-peer **

destination-pattern 911

forward-digits all

!

dial-peer voice 11 pots

corlist outgoing call-local

description ** T1 PRI pots dial-peer **

destination-pattern 9T

!

dial-peer voice 12 pots

corlist outgoing call-domestic

description ** T1 PRI pots dial-peer **

destination-pattern 9T

!

dial-peer voice 13 pots

corlist outgoing call-international

description ** T1 PRI pots dial-peer **

destination-pattern 900T

!

dial-peer voice 14 pots

corlist outgoing call-900

description ** T1 PRI pots dial-peer **

destination-pattern 91900.......

!

dial-peer voice 15 pots

corlist outgoing call-976

description ** T1 PRI pots dial-peer **

destination-pattern 91976.......

!

dial-peer voice 16 pots

description ** T1 PRI pots dial-peer **

incoming called-number .

direct-inward-dial

!

dial-peer voice 74 voip

description ** cue voicemail pilot number **

translation-profile outgoing PSTN_CallForwarding

destination-pattern 600

session protocol sipv2

session target ipv4:10.1.10.1

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 75 voip

description ** cue auto attendant number **

translation-profile outgoing PSTN_CallForwarding

destination-pattern 601

session protocol sipv2

session target ipv4:10.1.10.1

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 76 pots

destination-pattern 250

port 0/1/0

!

dial-peer voice 77 pots

destination-pattern 0

port 0/3/0

forward-digits 1

p.maillot Mon, 12/22/2008 - 05:23

telephony-service

load 7960-7940 P00307020200

load 7970 P00307020200

load 7906 P00307020200

max-ephones 150

max-dn 480

ip source-address 10.10.10.1 port 2000

auto assign 110 to 120

caller-id block code *916

calling-number initiator

service phone videoCapability 1

system message Banque Atlantique

time-zone 5

date-format dd-mm-yy

voicemail 600

max-conferences 8 gain -6

call-forward pattern .T

call-forward system redirecting-expanded

moh music-on-hold.au

web admin system name admin secret 5 $1$kscD$yxr4NQKAcnqvH1nO/QPgT/

dn-webedit

time-webedit

transfer-system full-consult dss

transfer-pattern .T

create cnf-files version-stamp 7960 Dec 20 2008 09:06:21

!

!

ephone-dn 1

number 301

name IP-Paging1

paging ip 239.1.1.1 port 2000

!

!

ephone-dn 2

number 302

name IP-Paging2

paging ip 239.1.1.2 port 2000

!

!

ephone-dn 3

number 303

name IP-Paging3

paging ip 239.1.1.3 port 2000

!

!

ephone-dn 4

number 304

name IP-Paging4

paging ip 239.1.1.4 port 2000

!

!

ephone-dn 5 dual-line

number 100 secondary 4085551000

label 100

description User Name

name CISCO

call-forward busy 600

call-forward noan 600 timeout 15

corlist incoming user900-international

!

!

ephone-dn 6 dual-line

number 101 secondary 4085551001

label 101

description User Name

name User Name

call-forward busy 600

call-forward noan 600 timeout 15

corlist incoming user900-international

!

!

ephone-dn 7 dual-line

number 102 secondary 4085551002

label 102

description User Name

name User Name

call-forward busy 600

call-forward noan 600 timeout 15

corlist incoming user900-international

!

!

ephone-dn 8 dual-line

number 103 secondary 4085551003

label 103

description User Name

name User Name

call-forward busy 600

call-forward noan 600 timeout 15

corlist incoming user900-international

!

!

ephone-dn 9 dual-line

number 104 secondary 4085551004

label 104

description User Name

name User Name

call-forward busy 600

call-forward noan 600 timeout 15

corlist incoming user900-international

!

!

ephone-dn 10 dual-line

number 105

label 105

description User Name

name User Name

call-forward busy 600

call-forward noan 600 timeout 15

corlist incoming user900-international

!

!

ephone-dn 151 dual-line

number 246

label 246

description User Name

name User Name

call-forward busy 600

call-forward noan 600 timeout 15

corlist incoming user900-international

!

!

ephone-dn 152 dual-line

number 247

label 247

description User Name

name User Name

call-forward busy 600

call-forward noan 600 timeout 15

corlist incoming user900-international

!

!

ephone-dn 153 dual-line

number 248

label 248

description User Name

name User Name

call-forward busy 600

call-forward noan 600 timeout 15

corlist incoming user900-international

!

!

ephone-dn 154 dual-line

number 249

label 249

description User Name

name User Name

call-forward busy 600

call-forward noan 600 timeout 15

corlist incoming user900-international

!

!

ephone-dn 155

number 800...

mwi on

!

!

ephone-dn 156

number 801...

mwi off

!

!

ephone-dn 157

number 701

park-slot

!

!

ephone-dn 158

number 702

park-slot

!

!

ephone-dn 159

number 703

park-slot

!

!

ephone-dn 160

number 704

park-slot

!

!

ephone-dn 161

number 705

park-slot

!

!

ephone-dn 162

number 706

park-slot

!

!

ephone-dn 163

number 707

park-slot

!

!

ephone-dn 164

number 708

park-slot

!

p.maillot Mon, 12/22/2008 - 05:24

ephone 1

video

mac-address 0022.90BC.20A8

username "100" password 0000

type 7960

button 1:5

pin 0000

!

!

!

ephone 2

video

mac-address 001C.58F9.8BE1

after-hour exempt

username "user2" password 101

type 7970

button 1:6

!

!

!

ephone 3

video

mac-address 0000.0000.0003

username "user3" password 102

type 7960

button 1:7

!

!

!

ephone 4

video

mac-address 0000.0000.0004

username "user4" password 103

type 7960

button 1:8

!

!

!

ephone 5

video

mac-address 0000.0000.0005

username "user5" password 104

type 7960

button 1:9

!

!

!

ephone 6

video

mac-address 0000.0000.0006

username "user6" password 105

type 7960

button 1:10

!

!

!

ephone 7

video

mac-address 0000.0000.0007

username "user7" password 106

type 7960

!

!

!

ephone 8

video

mac-address 0000.0000.0008

username "user8" password 107

type 7960

!

!

!

ephone 9

video

mac-address 0000.0000.0009

username "user9" password 108

type 7960

!

!

!

ephone 10

video

mac-address 0000.0000.0010

username "user10" password 109

type 7960

!

!

ephone-hunt 1 sequential

pilot 501

final 600

statistics collect

!

!

ephone-hunt 2 sequential

pilot 502

final 600

statistics collect

!

!

ephone-hunt 3 sequential

pilot 503

final 600

statistics collect

!

!

ephone-hunt 4 sequential

pilot 504

final 600

statistics collect

!

!

alias exec cue service-module service-engine 3/0 session

!

line con 0

line aux 0

line 194

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

privilege level 15

password cisco

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

ntp master

ntp server 10.10.10.1

!

end

CallManager#

hassan_oudeh Mon, 12/22/2008 - 05:58

looks like fine from the config point of view except im not getting why there is NO T1/E1 for all your dail-peer !!! local LD and international there are not pointing to anything ??!!

now let me understand you well, if you pick up a phone a call "0" only the 4 FXS ports are ringing ??!!!

if yes try to configure :

ephone-dn x

number 0

call-forward all 100

and make sure you can call 100 directly which is the FXS port !!

hope will help..HTH

p.maillot Mon, 12/22/2008 - 06:20

Actually my analog phone have the number 250

dial-peer voice 76 pots

destination-pattern 250

port 0/1/0

All all extension can call the analog phone

I have put the number "0" to take the FXO port 0/3/0

dial-peer voice 77 pots

destination-pattern 0

port 0/3/0

forward-digits 1

When I dial the number 0 I see an activity on the FXO card but I have no tone

hassan_oudeh Mon, 12/22/2008 - 08:31

now port 0/3/0 is FXO not FXS ?

if yes what are you trying to achive from your setup ?

call 0 as access code to get line then call outside ?

p.maillot Mon, 12/22/2008 - 08:46

Port 0/3/0 = FXO

Port 0/1/0 = FXS

Phone 250 is connected on FXS port 0/1/0 and I want dial 0 to take the line 0/3/0 to send an outgoing call.

Correct Answer
hassan_oudeh Mon, 12/22/2008 - 08:59

ok then forward all the dialed digits.

for example for loca calls you will dial 0 then the 7 digits number as below:

dial-peer voice 10 pots

destination-patter 0[2-9]......

port 0/3/0

forward digits 7

try that

p.maillot Mon, 12/22/2008 - 10:34

With it's running

dial-peer voice 77 pots

destination-patter 0[2-9]......

port 0/3/0

forward digits 0

hassan_oudeh Mon, 12/22/2008 - 15:11

your config :

dial-peer voice 77 pots

destination-patter 0[2-9]......

port 0/3/0

forward digits 0 <-- this will not send any digit to FXO, so it wont work.

you need to send the calles number to FXO in order to make your call

regards

Actions

This Discussion