Multicast MoH issue in SRST/CME

Unanswered Question
Dec 21st, 2008

Symptom

-------

I'm testing the MoH between IP Phones in the LAB (No PSTN available)

1. in normal mode, remote IP phone can get MoH from local SRST/CME router successfully

2. in SRST/CME mode, I hear ToH when press Hold button in remote IP Phone

CCM6.1.2 configuration

----------------------

-g729 between HQ and remote office

-create a region to assign g711 between MoH server and remote office

-MoH server=enable multicast(239.1.1.1, port 16384, increment=port numner, max hops=1)

SRST/CME configuration

----------------------

!

ip multicast-routing

!

interface GigabitEthernet0/0

ip address 10.0.29.2 255.255.255.0

!

interface GigabitEthernet0/1

no ip address

duplex full

speed 100

!

interface GigabitEthernet0/1.22

encapsulation dot1Q 22

ip address 10.0.22.1 255.255.255.0

!

interface GigabitEthernet0/1.23

encapsulation dot1Q 23

ip address 10.0.23.1 255.255.255.0

ip helper-address 10.0.131.11

ip pim sparse-mode

!

ccm-manager mgcp

ccm-manager music-on-hold

!

mgcp

mgcp call-agent 10.0.131.11 service-type mgcp version 0.1

!

telephony-service

video

srst mode auto-provision none

srst dn template 1

srst dn line-mode dual

max-ephones 52

max-dn 192

ip source-address 10.0.23.1 port 2000

max-redirect 20

system message Lost IP WAN, in SRST Mode!!

sdspfarm units 1

sdspfarm tag 1 conf

time-format 24

voicemail 3200

max-conferences 16 gain -6

call-forward pattern .T

moh music-on-hold.au

multicast moh 239.1.1.1 port 16384 route 10.0.23.1

transfer-system full-consult

transfer-pattern .T

secondary-dialtone 9

!

!

ephone-dn-template 1

call-forward busy 3200

call-forward noan 3200 timeout 12

!

ops1srst#sh ephone summary

..

Active MOH clients 0 (max 196), Media Clients 0, B-ACD Clients 0

File music-on-hold.au type AU Media_Payload_G711Ulaw64k 160 bytes

Moh multicast on 239.1.1.1 port 16384 via 10.0.23.1

I exactly followed the CCO instruction but I hear ToH in SRST/CME mode. Advise please!!!

Thanks in advance,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marwan ALshawi Sun, 12/21/2008 - 12:57

put on the source address interface

h323 voip interface

h323 voip bind srr add 10.0.23.1

if didnt work make the wource interface as a loopback interface make it the source for voip and for sccp as well and add it to the moh multicast route

also try to remove the moh config and re put it again

good luck

Actions

This Discussion