Transfer analog phone to IP Phone

Unanswered Question
Dec 22nd, 2008
User Badges:

Hello,


I have a problem to transfer a call to analog phone from an IP Phone. On IP Phone, I can dial only two digit and after hook.


On analog phone, how to enable the transfer key? It's possible to use the "R" key on the phone keyboard?


There no problem of transfer ip phone to ip phone.


Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
p.maillot Mon, 12/22/2008 - 02:06
User Badges:

I have add this command, but now the transfer is permit between anlog phone and IP Phone but transfer is not immediate, I must wait 5seconds or more. There are a solution for transfer immediate without time?


How to enable the transfer on analog phone?



CallManager(config-telephony)#transfer-pattern .T


CallManager(config-telephony)#call-forward pattern .T


david-lima Mon, 12/22/2008 - 05:08
User Badges:
  • Bronze, 100 points or more

Hi, maybe you could try a specific transfer pattern according to your dial-plan.

CallManager(config-telephony)#transfer-pattern ....

CallManager(config-telephony)#call-forward pattern ....

Or decrease the interdigit timeout (default is 15 sec).

CallManager(config-telephony)#timeout interdigit "value 2 to 120 sec"

Hope this help

David

p.maillot Mon, 12/22/2008 - 05:57
User Badges:

I have try that


CallManager(config-telephony)#transfer-pattern 55

CallManager(config-telephony)#call-forward pattern 56


On analog phone I call IP Phone 100 and now I want to transfer the call to the IP Phone 101 but on analog phone if I dial 56 or 55 or other nothing happens

p.maillot Mon, 12/22/2008 - 08:49
User Badges:

Sorry, I don't understand.

When you are on an anolog phone how to transfer a call to an another extension?

Nicholas Matthews Mon, 12/22/2008 - 09:17
User Badges:
  • Red, 2250 points or more

That is in the document that I sent. You have to register that port with SCCP, and then you have to set up feature codes where you dial *2 and then the number, and things like that.


It's quite a bit of configuration. I suggest reading through the links I sent.

p.maillot Mon, 12/22/2008 - 10:27
User Badges:

I have put


Router(config)#stcapp feature access-code


Router#sh stcapp feature codes


stcapp feature access-code

prefix **

call forward all **1

call forward cancel **2

pickup local group **3

pickup different group **4

pickup direct **6


stcapp feature speed-dial disabled


Maybe I have forgot something? But when I dial **1 to tranfer a call nothing it happens.


Regards


Nicholas Matthews Mon, 12/22/2008 - 11:30
User Badges:
  • Red, 2250 points or more

Yes, you need the entire sccp configuration.


It will look like:


sccp

sccp ccm group 1

ass ccm 1 pri 1

....

p.maillot Tue, 12/23/2008 - 00:19
User Badges:

I have always the same problem, I want to transfer a call from my analog phone but when I dial feature access-code key on my analog keyboad nothing it happens,maybe I have do somting wrong?


See my conf

My FXS phone is on port 0/1/0


stcapp ccm-group 1

stcapp

!

stcapp feature access-code

prefix *#

call forward all 2

call forward cancel 9


voice-port 0/1/0

caller-id enable


sccp local GigabitEthernet0/1

sccp ccm 192.168.0.13 identifier 2

sccp ccm 192.168.0.12 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate ccm 2 priority 2


dial-peer voice 76 pots

destination-pattern 250

port 0/1/0


dial-peer voice 78 pots

service stcapp

port 0/1/0



Nicholas Matthews Tue, 12/23/2008 - 10:13
User Badges:
  • Red, 2250 points or more

check 'show sccp' to see if the analog port is registered

p.maillot Tue, 12/23/2008 - 22:43
User Badges:

CallManager#sh sccp

SCCP Admin State: UP

Gateway IP Address: 192.168.0.1, Port Number: 2000

IP Precedence: 5

User Masked Codec list: None

Call Manager: 192.168.0.12, Port Number: 2000

Priority: N/A, Version: 3.1, Identifier: 1

Call Manager: 192.168.0.13, Port Number: 2000

Priority: N/A, Version: 3.1, Identifier: 2


Alg_Phone Oper State: ACTIVE_IN_PROGRESS - Cause Code: TCP_CONN_ERROR

Active Call Manager: NONE

TCP Link Status: NOT_CONNECTED, Device Name: AN2255E60821080

Reported Max Streams: 1, Reported Max OOS Streams: 0

Supported Codec: g711ulaw, Maximum Packetization Period: 20

Supported Codec: g711alaw, Maximum Packetization Period: 20

Supported Codec: g729r8, Maximum Packetization Period: 220

Supported Codec: g729ar8, Maximum Packetization Period: 220

Supported Codec: g729br8, Maximum Packetization Period: 220

Supported Codec: g729r8, Maximum Packetization Period: 220



Nicholas Matthews Wed, 12/24/2008 - 05:46
User Badges:
  • Red, 2250 points or more

It's not registered. You will need to go back and check your sccp configuration, as well as your CME configuration.



hth,

nick

Actions

This Discussion