Change telnet password on ASA

Unanswered Question
Dec 22nd, 2008
User Badges:

Hi,


On my ASA if I SSH to it I can put the same username and password I use when I use the ASDM, however when I tlenet to the ASA it just says password, I simply put in "password" and it lets me, then asks for my username and password, how do I change this first telnet password?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
John Blakley Mon, 12/22/2008 - 14:09
User Badges:
  • Purple, 4500 points or more

Your telnet line pulls from the enable password if you don't have AAA authentication enabled. You can change the password with:


enable secret


HTH,


John

I disagree :)..


For your password, you need to enter this


ASA(config)#passwd your_telnet_password


annd one john said, to change the enable commmand, you need to enter


ASA(config)#enable password your_enable_password



Enable password in ASA is equivilant to enable secret in router/switches. There is no enable secret in ASA.


pls rate if helpful.


regards,

Mohsin

whiteford Tue, 12/23/2008 - 00:58
User Badges:

Hi,


I managed to change the password.


What is confusing (could AAA be enabled):


1.) If I login via telnet I get prompted for a password which I enter, then I get to the user mode (I think) and then type enable and it have to enter my priviliged 15 username and password which I use for the ASDM or SSH.


2.) If I login via SSH I have to enter my level 15 username and password, then when I type enable I have to put my level 15 password in again and not the enable secret password I use in telnet.


All this sound normal?

John Blakley Tue, 12/23/2008 - 03:39
User Badges:
  • Purple, 4500 points or more

For the record, I was wrong. :-) Mohsin was right about passwd changing the telnet password. As for the other, can you post the config? It doesn't make sense.


HTH,


John

Actions

This Discussion